投稿日:2006年07月08日 作成鷹の巣

No.20821 sendmane.exeの単体送信テストで、10053エラーになってしまいます。



sendmane.exeの単体送信テストで、10053エラーになってしまいます。

No.20821 投稿時間:2006年07月08日(Sat) 10:40 投稿者名:cos URL:

sendmane.exeの単体送信テスト
C:\sendmane>type sendtest.txt | sendmane [あなたのメールアドレス]
をすると、エラーは出ずにコマンドプロンプトが返ってきます。
しかし、送信先には送信されておらず、ログを見ると10053エラーが出ていると書いてあります…

調べてみると10053エラーは「通信が切断された」という事らしいのですが、
なぜ切断されたのか分かりません。

メールサーバーは
ArGoSoft Mail Server Version 1.8 を使っています。
SMTP認証はしていません。


何が原因と考えられるでしょうか…?
お力添えをお願いします。



以下は周辺のログです。

2006/07/08 午前 10:26:43 - Requested SMTP connection from 127.0.0.1
2006/07/08 午前 10:26:43 - ( 34) 220 ***.***.net ArGoSoft Mail Server Freeware, Version 1.8 (1.8.8.7)
2006/07/08 午前 10:26:43 - ( 34) EHLO 127.0.0.1
2006/07/08 午前 10:26:44 - ( 34) 250-Welcome [127.0.0.1], pleased to meet you
2006/07/08 午前 10:26:44 - ( 34) 250-AUTH=LOGIN
2006/07/08 午前 10:26:44 - ( 34) 250-AUTH LOGIN
2006/07/08 午前 10:26:44 - ( 34) 250-SIZE 5242880
2006/07/08 午前 10:26:44 - ( 34) 250 HELP
2006/07/08 午前 10:26:44 - ( 34) MAIL FROM:<web@***.***.net>
2006/07/08 午前 10:26:44 - ( 34) 250 Sender "web@***.***.net" OK...
2006/07/08 午前 10:26:45 - ( 34) RCPT TO:<cos@***.***.net>
2006/07/08 午前 10:26:45 - ( 34) 250 Recipient "cos@***.***.net" OK...
2006/07/08 午前 10:26:45 - Error: [10053] Software caused connection abort
2006/07/08 午前 10:26:45 - SMTP connection with 127.0.0.1 ended. ID=34


安易な切り分け方法

No.20831 投稿時間:2006年07月10日(Mon) 11:16 投稿者名:通-行-人 URL:

> sendmane.exeの単体送信テスト
> C:\sendmane>type sendtest.txt | sendmane [あなたのメールアドレス]
> をすると、エラーは出ずにコマンドプロンプトが返ってきます。
> しかし、送信先には送信されておらず、ログを見ると10053エラーが出ていると書いてあります…
>
> 調べてみると10053エラーは「通信が切断された」という事らしいのですが、
> なぜ切断されたのか分かりません。

サーバ機で telnet.exe を立ち上げ、
「set crlf」 (Enter キーに対し CR と LF を送信)
「set localecho」 (ローカルエコーあり)
を入力し、
「open 127.0.0.1 25」 (127.0.0.1 の 25 番ポートへ接続)
を入力し、 サーバの応答に対し
「EHLO 127.0.0.1」
「MAIL FROM:<web@***.***.net>」
「RCPT TO:<cos@***.***.net>」
「DATA」
「Test message.」 (次のピリオドを入力するまで、 サーバは応答を返しません。)
「.」
「QUIT」
を順次入力してみて、 途中で切断されるようであれば ArGoMail 側の問題、 QUIT まで行けるのなら sendmane 側の問題、 という切り分けができるかと思います。

注意: Win9X 系の telnet.exe では set や open のコマンドは使えません。打鍵方法で細工をする必要があります。

ArGoMail のテスト環境を Win9x 系のみにしてしまったので、 詳しいことは調べられません。
どうもこのソフト、 WinNT のアクセス権周りがあまり考慮されていないように思うのです。


目次掲示板過去ログ目次▲頁先頭