投稿日:2005年02月09日 作成鷹の巣

No.18315 AN HTTPDで、携帯用ページ(xhtml)にアクセスすると500エラーが発生する。



AN HTTPDで、携帯用ページ(xhtml)にアクセスすると500エラーが発生する。

No.18315 投稿時間:2005年02月09日(Wed) 07:18 投稿者名:KPSN URL:

いつもお世話になっております。
で,一つ質問させて下さい。携帯用ページをレンタルサーバから自宅サーバへ移行し,
携帯でアクセスしテストしたところ,2度ほどは正常表示できた後に,
『ページを表示できません 500』となってしまいます。
当初は記述を疑いましたが,レンタルサーバでは正常に表示できていたため,サーバを
疑ったのですが,ほとんど掲示板やCGIでのケースしか見られないようで,調べても全然
対策法を得られませんでした。
記述は,xhtmlで,.htmlファイルです。
サーバソフトは,AN HTTPDを使っており,テスト用携帯はau A5502Kです。
どうかご教授ください。宜しくお願い致します。


サーバーのエラーログを見てみましょう。

No.18316 投稿時間:2005年02月09日(Wed) 07:33 投稿者名:Iwa URL:http://www.ethersky-online.net/

サーバーのエラーログを見てみましょう。
自宅サーバーであるならレンタルの場合とは違い、自分が管理者なわけですからログくらいみれますし。


エラーログには残っていませんでした。

No.18331 投稿時間:2005年02月10日(Thu) 02:09 投稿者名:KPSN URL:http://kpsn.dynalias.net/mobile/

ログは毎回見ているのですが,エラーログにその時間の記録は残っていません。
動作ログでは,該当ページをちゃんと公開しているように記録されているのですが…
イマイチぴんと来ないのが現状です。

該当ページを参照先に記載しておきますので,記述違いや携帯ブラウザでのエラー状況を
教えて頂けると大変幸いです。
ちなみに,au W11Kでのテストも500エラーとなったようです。
これも同様に,エラーログには残っていませんでした。
設定では,エラーログを全て残すようにしてありますが…。


DoCoMo P504iSではちゃんと見れてます。

No.18344 投稿時間:2005年02月11日(Fri) 16:14 投稿者名:Iwa URL:http://www.ethersky-online.net/

AUではないですが、DoCoMo P504iSではちゃんと見れてます。
なお、XHTMLの文法的な点でいえば、けっこうめちゃくちゃですね。
(ウチもサイト全般をXHTMLで書いてますが、XHTMLでは全てのタグを閉じないといけないなど、制約が多々あります。)

詳しい指摘は
http://openlab.ring.gr.jp/k16/htmllint/index.html
で受けてください。

ただ、今回の500の件とは直接関係ないとおもいますけど。


記述を直してみようと思います。

No.18358 投稿時間:2005年02月12日(Sat) 23:07 投稿者名:KPSN URL:

ご検証大変助かります。
ありがとうございます。記述を確かめつつ直してみることを課題としてみます。
お手数をおかけしました事,大変申し訳ありません。
auですと,すぐに500エラーが返ってくるため,KDDIでの記述修正に時間がかかるために,
内部エラー500を返すのかもしれません。
故に,記述を直してみようと思います。
それでも改善されなかった場合には,またお世話になるかとは思いますが,その時も大変心苦しい
ですが,宜しくお願いしたいと思います。
勝手ではありますが,今後もお願い致します!


|目次|掲示板|過去ログ目次|▲頁先頭|