投稿日:2004年09月16日 作成鷹の巣

No.17244 bind9.2.2へのアップデートでどのパッケージを選んで良いのかわからない。



bind9.2.2へのアップデートでどのパッケージを選んで良いのかわからない。

No.17244 投稿時間:2004年09月16日(Thu) 09:48 投稿者名:群青 URL:

初めまして。
現在bind9.2.1からbind9.2.2へのアップデートを行おうとしている
のですが、のっけからワケがわからず困っています。どなたかご教授願えませんか?
状況:
Turbolinux7
bind9.2.1はソースコードからインストールしたらしい(自分で行ってはいない)
rpmパッケージでアップデートする。

パッケージ自体は見つかりますが、どれを選んで良いのかよくわかりません。
またrpmコマンドでとにかく落としてきたパッケージ(bind-9.2.2.P3-9.i386.rpm)を試してみた処、

error: failed dependencies
libc.so.6(GLIBC_2.3) is needed by bind-9.2.2.P3-9
libcrypto.so.4 is needed by bind-9.2.2.P3-9
libdns.so.10 is needed by bind-9.2.2.P3-9
libisc.so.4 is needed by bind-9.2.2.P3-9
liblwres.so.1 is needed by bind-9.2.2.P3-9
rpmlib(PartialHardlinkSets) <= 4.0.4-1 is needed by bind-9.2.2.P3-9

というエラーが出ました。何かを必要としている事は察する事ができますが、
具体的に何を用意すればよいのかよく分からない状態です。

そもそもLinux自体初めて触るのであらゆる事が不明です。
どなたかアドバイスをお願いします!何卒!


ソースから入れて下さい。

No.17245 投稿時間:2004年09月16日(Thu) 12:30 投稿者名:松元 URL:

bind9.2.3 がリリースされているのに bind9.2.2 を入れるのですか?
バイナリーのRPMは特定デストリビューション専用みたいなものですからソースから入れて下さい。
やり方はあちこち書いてあります。難しくは有りません。それが出来ないなら9.2.1のままお使い下さい。
どうしてもバイナリーでやりたいなら多分分かっていると思いますが、足りないLIBを持って来れば動くはずです。
但し、そのバイナリーはturbo7用では無いのではないですか。


足りないものを片っ端から集めてトライしてみようと思います。

No.17247 投稿時間:2004年09月16日(Thu) 18:27 投稿者名:群青 URL:

> bind9.2.3 がリリースされているのに bind9.2.2 を入れるのですか?
> バイナリーのRPMは特定デストリビューション専用みたいなものですからソースから入れて下さい。
> やり方はあちこち書いてあります。難しくは有りません。それが出来ないなら9.2.1のままお使い下さい。
> どうしてもバイナリーでやりたいなら多分分かっていると思いますが、足りないLIBを持って来れば動くはずです。
> 但し、そのバイナリーはturbo7用では無いのではないですか。

ありがとうございます。
どうやらワケありで9.2.2を使いたいらしく、バイナリがturbo7用でなかなか見つからない旨を
今回の件を指示された方に報告した処、多分大丈夫だからと、適当なモノで行っていました。

足りないものを片っ端から集めてトライしてみようと思います。
どうもありがとうございました!


bind-9.2.4rc8のリリース。

No.17252 投稿時間:2004年09月17日(Fri) 00:16 投稿者名:stranger URL:

> > bind9.2.3 がリリースされているのに bind9.2.2 を入れるのですか?
> > バイナリーのRPMは特定デストリビューション専用みたいなものですからソースから入れて下さい。
> > やり方はあちこち書いてあります。難しくは有りません。それが出来ないなら9.2.1のままお使い下さい。
> > どうしてもバイナリーでやりたいなら多分分かっていると思いますが、足りないLIBを持って来れば動くはずです。
> > 但し、そのバイナリーはturbo7用では無いのではないですか。
> > ありがとうございます。
> どうやらワケありで9.2.2を使いたいらしく、バイナリがturbo7用でなかなか見つからない旨を
> 今回の件を指示された方に報告した処、多分大丈夫だからと、適当なモノで行っていました。
> > 足りないものを片っ端から集めてトライしてみようと思います。
> どうもありがとうございました!

きっと見にこないでしょうけど
開発者からのアナウンス
bind-9.2.4rc8のリリース
過去のbugの修正の情報など
http://marc.theaimsgroup.com/?l=bind-announce&m=109426440503856&w=2


|目次|掲示板|過去ログ目次|▲頁先頭|