投稿日:2004年05月06日 作成鷹の巣

No.15873 Apache2へのバージョンアップで、以前のhttpd.confをそのままコピーして使用できるのでしょうか?



Apache2へのバージョンアップで、以前のhttpd.confをそのままコピーして使用できるのでしょうか?

No.15873 投稿時間:2004年05月06日(Thu) 12:55 投稿者名:こあ URL:

Windows2000でApache2.0.48を使っています。
Ver.2.0.49が出たので、バージョンアップしてみたいのですが、
apache_2.0.49-win32-x86-no_ssl.msiをダウンロードして、
そのままインストールすれば、httpd.confの内容は変わらずに、
アップデート出来るのでしょうか?

あと、Windows版Apache2は、一部掲示板cgiで名前欄のcookieが文字化けするバグとかあるらしいので、
Apache1.3.29に変えようかとも思っています。
この場合、2.0.48をアンインストールした後、1.3.29をインストールしてhttpd.confをコピーで
良いものでしょうか…

以上、宜しくお願いします。


Apache1とApache2は別物と思った方が良いです。

No.15874 投稿時間:2004年05月06日(Thu) 14:08 投稿者名:stranger URL:

> Windows2000でApache2.0.48を使っています。
> Ver.2.0.49が出たので、バージョンアップしてみたいのですが、
> apache_2.0.49-win32-x86-no_ssl.msiをダウンロードして、
> そのままインストールすれば、httpd.confの内容は変わらずに、
> アップデート出来るのでしょうか?
> > あと、Windows版Apache2は、一部掲示板cgiで名前欄のcookieが文字化けするバグとかあるらしいので、
> Apache1.3.29に変えようかとも思っています。
> この場合、2.0.48をアンインストールした後、1.3.29をインストールしてhttpd.confをコピーで
> 良いものでしょうか…
> > 以上、宜しくお願いします。

Apache1.3.29にもcookieのバグがあると公式サイトにはありますが・・・
Apache1とApache2は別物と思った方がよいです
Apache1を使うのであれば httpd.confを書き直す

httpd.confを別の場所に移動しておいて インストールしたらどうですか
新しくインストールされたものと比べて、httpd.confを修正した方が良いです
2.0.48から2.0.49にアップした場合
linux版では下記内容が追加されただけですが、windoes版はわかりません
<IfModule mpm_netware.c>
MaxMemFree 100
</IfModule>


2.0系の設定ファイルを1.3系では使えません。また逆も出来ません。

No.15876 投稿時間:2004年05月06日(Thu) 19:28 投稿者名:APACHE URL:http://kemuri-net.dip.jp/~server/worm.txt

> Windows2000でApache2.0.48を使っています。
> Ver.2.0.49が出たので、バージョンアップしてみたいのですが、
> apache_2.0.49-win32-x86-no_ssl.msiをダウンロードして、
> そのままインストールすれば、httpd.confの内容は変わらずに、
> アップデート出来るのでしょうか?
同系統ならそのまま使うことが出来ます。
※本家で互換性に関するアナウンスがあった場合は除く

> あと、Windows版Apache2は、一部掲示板cgiで名前欄のcookieが文字化けするバグとかあるらしいので、
> Apache1.3.29に変えようかとも思っています。
> この場合、2.0.48をアンインストールした後、1.3.29をインストールしてhttpd.confをコピーで
> 良いものでしょうか…
1.3系統と2.0系統では設定子などが異なるので、2.0系の設定ファイルを1.3系では使えません。
また逆も出来ません。

ウチは両方入れて設定だけすませて2.0系は眠らせています。


|目次|掲示板|過去ログ目次|▲頁先頭|