投稿日:2004年04月05日 作成鷹の巣

No.15526 自宅サーバーは無線LANだと外部から接続できないのでしょうか?



自宅サーバーは無線LANだと外部から接続できないのでしょうか?

No.15526 投稿時間:2004年04月05日(Mon) 00:21 投稿者名: URL:

皆さんに質問したいことがあります。
自宅サーバーは無線LANだと外部から接続できないのでしょうか?
色々試してみたのですがどうしても出来ません。
分かる方がいらっしゃいましたらお願いします!


私も無線LANでサーバーを試みましたが問題なく立てられました。

No.15539 投稿時間:2004年04月05日(Mon) 21:05 投稿者名:gyaa URL:

私も無線LANでサーバーを試みましたが問題なく立てられました。
可能なはずです!


ちゃんと、サーバー機のIPアドレスを固定し、ルータでIPマスカレードすれば問題ないはずです。

No.15540 投稿時間:2004年04月05日(Mon) 21:09 投稿者名:店主のピチュー URL:http://tenpichu.no-ip.com/

できなくはないはずです。
ちゃんと、サーバー機のIPアドレスを固定し、ルータでIPマスカレードすれば
問題ないはずです。

しかし、セキュリティ的に甘くなるうえ、回線が途切れやすいので
できれば有線LANがいいです。


使用しているモデム(ルータ機能付)はYahoo! BBのトリオモデムです。

No.15544 投稿時間:2004年04月05日(Mon) 22:53 投稿者名: URL:

レスありがとうございます!
使用しているモデム(ルータ機能付)はYahoo! BBのトリオモデムです。
色々試みたのですがさっぱり分かりません。
設定方法など分かる方、お願いします!


どういう状況までいったんですか?

No.15547 投稿時間:2004年04月06日(Tue) 00:51 投稿者名:gyaa URL:

どういう状況までいったんですか?
恐らく、ローカルIP固定したがルータ設定がわからん!という状況かな・・?
とにかくport開放せねばなりませんなぁ
私は富士通ですのでIPマスカレード設定やらスタティックIPやらの設定でしたが・・


Portが開放されているのかもわかりません。

No.15549 投稿時間:2004年04月06日(Tue) 01:01 投稿者名: URL:

一応ルータの設定はしたと思うのですが・・・もしかしたらまだ不十分かもしれません。
すみません、何も(ってわけではないですけど)わからないので・・・。
多分Portは開放したと思います。でもしてないかもしれません。
こんなボクですが、親切に教えてくださってありがとうございます!
Portが開放されているのかもわかりません。
諦めた方がいいのでしょうか・・・?


port開放の確認方法。

No.15550 投稿時間:2004年04月06日(Tue) 02:15 投稿者名:gyaa URL:

いや、まだ諦めるのは早いですよ!
私もport開放で半年ぐらい試行錯誤してましたから(w
port開放を確認するには、http://grc.com/default.htmで確かめられます。
「Hot spotsという所のShieldsUP!→Proceed→ShieldsUP!! Servicesという所の
Common Ports(大まかなportの状況を表示)もしくはAll Service Ports(0番から1055番までのportの状況を表示)」
これで確認するときにサーバーソフトが起動している状態でやって下さい。
ここで表示されるportの状態は3種類あってOpen(port開放されている)、Closed(閉じている)Stealth(一番安全な状態、火壁有効)
私は、メルコ製無線LANアダプタ(WLI-USB-L11G)+メルコ製アクセスポイント(WLA-B11)+AN HTTPD+Out Post
の環境で一応Webサーバーは立ち上がりました。


Port80は開いているみたいです。

No.15552 投稿時間:2004年04月06日(Tue) 12:44 投稿者名: URL:

早速確かめてみました!
Port80は開いているみたいです。
あとは何をすればいいのでしょうか?
質問ばかりでスミマセン・・・。


ファイアウォールソフトがありますか?

No.15553 投稿時間:2004年04月06日(Tue) 13:06 投稿者名:店主のピチュー URL:http://tenpichu.no-ip.com/

サーバーにファイアウォールソフト(以下FW)がありますか?
Zone Alermなどに限らず、ウィルスバスターやノートンパーソナルファイアウォール・インターネットセキュリティなどです。

もし、そういうFWがあった場合、そのFWからもアクセスを許可しなければなりません。
また、ルータを使っている場合は頑丈なほどまでFWを使う必要はないと考えます。

いかがでしょうか?


ウィルスバスターを使用しています。

No.15554 投稿時間:2004年04月06日(Tue) 13:16 投稿者名: URL:

ウィルスバスターを使用しています。
しかしセキュリティレベルを「低」に設定してあるので、多分大丈夫だと思われます。

↑の事とは関係ないのですが、パソコン1台でも大丈夫ですよね?


1台でも

No.15558 投稿時間:2004年04月06日(Tue) 16:19 投稿者名:店主のピチュー URL:http://tenpichu.no-ip.com/

1台でも無線LANで接続できますよ。


火壁でhttpd.exe(サーバソフト)の通信を許可してやらなくては。

No.15565 投稿時間:2004年04月06日(Tue) 21:44 投稿者名:gyaa URL:

そうですね。
火壁(私の場合はOut Post)でhttpd.exe(サーバソフト)の通信を許可してやらなくては。


ありがとうございます!

No.15566 投稿時間:2004年04月06日(Tue) 23:14 投稿者名: URL:

皆さん色々とありがとうございました!
ここ辺りまで来るとそろそろ開通できますか?
まだ必要な事などがあったら教えてください。お願いします。


WebサーバのテストページでWAN側から見れるかどうか確認しましょう。

No.15567 投稿時間:2004年04月06日(Tue) 23:25 投稿者名:gyaa URL:

もう大丈夫じゃないですかね?
Webサーバのテストページ(http://www.aconus.com/~oyaji/www_tst/www_tst.htm)
でWAN側から見れるかどうか確認しましょう。
それで確認がとれたらZiVE(http://www.zive.org/)でドメインを取得し、
DiCE(http://www.hi-ho.ne.jp/yoshihiro_e/dice/)との併用でもう完成ですかね。


Webサーバテストをしても何も表示されません。

No.15568 投稿時間:2004年04月06日(Tue) 23:41 投稿者名: URL:

Webサーバテストをしても何も表示されません。
やっぱりコレは出来ていないんでしょうか?


LAN内からは見れますよね?

No.15570 投稿時間:2004年04月07日(Wed) 00:39 投稿者名:gyaa URL:

そうですか・・・
LAN内からは見れますよね・・?


インターネットプロトコル、AnHTTPD、Outpostなどの設定を教えてくれたらうれしいです。

No.15571 投稿時間:2004年04月07日(Wed) 00:45 投稿者名: URL:

うちはパソコン1台だけなので・・・。
もしかしたらソフトウェアなどの設定が違うのかもしれません。
インターネットプロトコル、AnHTTPD、Outpostなどの設定を教えてくれたらうれしいです。
面倒かもしれませんが是非お願いします。
ほかに設定しなければならないものがありましたら、そちらもお願いします。


http://ローカルIPアドレス/で違う.htmlでアクセスしてみて下さい。

No.15572 投稿時間:2004年04月07日(Wed) 00:57 投稿者名:gyaa URL:

IEのアドレス欄にhttp://ローカルIPアドレス/ここは人によって違う.htmlでアクセスしてみて下さい。
ここで見れれば「LANからのアクセス可能=AN HTTPDの設定は合ってる=port80は開放済み=WAN側からアクセス可能」なはずです。
私の場合はhttp://192.168.0.5/~home/index.htmlになります。
AN HTTPDの設定は
自宅サーバーを立ち上げるぞ大作戦(http://juntake.zive.net/server/index.htm)を参照してみて下さい。

Out Postの設定はデフォルトのままでいいですが、送受信が行われるアプリケーションがあると
「送受信を許可しますか?」というような警告が逐一、表示されますからhttpd.exeの許可してやって下さい。


エラーで「指定されたWWWサーバのIPアドレス(192.168.3.2)はプライベートアドレスです。」と表示されます。

No.15573 投稿時間:2004年04月07日(Wed) 01:19 投稿者名: URL:

ウチにはPCが1台しかありません・・・。そのせいでしょうか・・・
エラーで「指定されたWWWサーバのIPアドレス(192.168.3.2)はプライベートアドレスです。」と表示されます。
このような場合はどぉすればいいのでしょうか?


テストページでローカルアドレスを入力するのでは無く、ブラウザのアドレス欄に直接、入力して下さい。

No.15574 投稿時間:2004年04月07日(Wed) 01:24 投稿者名:gyaa URL:

テストページでローカルIPを入力するのでは無く、ブラウザのアドレス欄に直接、入力して下さい。


それは出来ました。

No.15575 投稿時間:2004年04月07日(Wed) 01:40 投稿者名: URL:

それは出来ました!!(ヤッター!
インターネット外部から表示したい場合はどぉすればいいのですか?

Webサーバのテストページ(http://www.aconus.com/~oyaji/www_tst/www_tst.htm)
ではよく分からなかったし・・・

ZiVE(http://www.zive.org/)でドメインを取得し、
DiCE(http://www.hi-ho.ne.jp/yoshihiro_e/dice/)との併用で見れますか?


テストページでローカルアドレスをグローバルアドレスに換えて再度確認して下さい。

No.15576 投稿時間:2004年04月07日(Wed) 01:52 投稿者名:gyaa URL:

いや、まだ待って下さい。
もう、その状態ならWAN側からアクセスできるはずです。
テストページでローカルIPをグローバルIPに換えて再度確認して下さい。
グローバルIPはコロコロ変わってしまうことはご存知ですよね。

ローカルIPが
http:192.168.0.5/~home/index.htmlなら
テストページで
http://***.***.***/~home/index.htmlと入力。
ご存知の通り、***.***.***はその時のグローバルIP。


やはり真っ白のまま何も表示されません。

No.15577 投稿時間:2004年04月07日(Wed) 01:55 投稿者名: URL:

やはり真っ白のまま何も表示されません。


接続が異様に遅く、「エラーが発生しました。接続がタイムアウトしました。」と出ますか?

No.15578 投稿時間:2004年04月07日(Wed) 02:03 投稿者名:gyaa URL:

接続が異様に遅く、「エラーが発生しました。接続がタイムアウトしました。」と出ますか?
それともすぐに表示されるけど真っ白ですか?


すぐに表示されるけど真っ白です。

No.15579 投稿時間:2004年04月07日(Wed) 02:05 投稿者名: URL:

すぐに表示されるけど真っ白です・・・。
やっぱどっかで設定おかしいのかなぁ・・・ルータとか・・・

というか色々とありがとうございます!


index.htmlに何も書いてないとか?

No.15580 投稿時間:2004年04月07日(Wed) 02:07 投稿者名:gyaa URL:

index.htmlに何も書いてないとか・・?
うーむ・・・


index.htmlには「test」とだけ書いてあります。

No.15581 投稿時間:2004年04月07日(Wed) 02:09 投稿者名: URL:

index.htmlには「test」とだけ書いてあります。


「リンク先には飛ぶのに、何も表示されない」ってことですよね?

No.15582 投稿時間:2004年04月07日(Wed) 02:16 投稿者名:gyaa URL:

うーむ・・・私も分からなくなってきましたね・・
「リンク先には飛ぶのに、何も表示されない」ってことですよね・・?
自宅サーバを考えてらっしゃるわけですから当然、htmlタグはごときは理解してらっしゃいますよね。


htmlファイルの内容。

No.15583 投稿時間:2004年04月07日(Wed) 02:18 投稿者名: URL:

<html>
<head>
<title>test</title>
</head>
<body>
test
</body>
</html>

と書いてあります!


テストページからアクセスした時、タスクバーのアイコンが稲妻のようなアイコンに変わりますか?

No.15584 投稿時間:2004年04月07日(Wed) 02:40 投稿者名:gyaa URL:

確かに、問題はありませんね・・
「指定したURLには飛ぶが真っ白」は不思議ですな・・接続待ちでは無いと・・
テストページからですよね。

ではテストページからアクセスした時、タスクバーに収まっているAN HTTPDのアイコンが通信中を思わせるような
稲妻のようなアイコンに変わりますか?


変わりません。

No.15593 投稿時間:2004年04月07日(Wed) 15:44 投稿者名: URL:

変わりません・・・。
AnHTTPDの設定がいけないのでしょうか・・・?


PCは1台ですが

No.15585 投稿時間:2004年04月07日(Wed) 07:44 投稿者名:店主のピチュー URL:http://tenpichu.no-ip.com/

PCは1台(サーバーとクライアント共有)のようですが、
どのようにインターネットに接続していますか?
A.モデムを直接接続して、接続
B.モデムルータ、もしくは普通のルータから接続
C.モデムのルータ機能がON、しかし普通のルータも購入。

もしB&の場合はIPマスカレードをしなければなりませんが・・・。


アイコンが変わらないということはやはりルータ設定がまだ完璧でないんでしょう、多分。

No.15594 投稿時間:2004年04月07日(Wed) 16:22 投稿者名:gyaa URL:

アイコンが変わらないということはやはりルータ設定がまだ完璧でないんでしょう、多分。
LAN内からアクセス可能だったわけですからAN HTTPDの設定はあってるはずです。
タスクバーのアイコンの変化をupしました
ご参照下さい→(http://venus.aez.jp/uploda/dat/upload5836.bmp)

しかし、port80は開放確認できたんですからもう大丈夫だと思うんですがね・・


老婆心ながら

No.15595 投稿時間:2004年04月07日(Wed) 18:54 投稿者名:ぷららユーザー URL:

一度トリオモデムの電源コネクタを引っこ抜いてみるのはどうでしょうか。

深呼吸をして気持ちを落ち着かせてから、おもむろにトリオモデムの電源を
再投入してみると解決するかも(あくまでも「かも」)しれません。

うちはY!BBではありませんが、やはりWAN側からアクセスできなかった時、
いったん全部電源を落として、モデム→ルーター→サーバーの順でそれぞれ
少しずつ時間を空けて(ランプが通常通り点灯するくらい)電源を再投入を
行なって解決したことがあります。


ログとエンコードについて

No.15596 投稿時間:2004年04月07日(Wed) 20:34 投稿者名:ryujin URL:http://ryujin.info/

はじめまして、徹さん。

ちょいと気になったところだけ書いて見ます。

下記2つのログを確認してみてください。
・おやじさんの接続テストにてのWWWサーバテスト・ログ
・自分のWebサーバーログ
また、真っ白と言うのは、その時の
・ブラウザーのエンコードは何になっていますか?


エンコードというのがいまいち分かりませんでした。

No.15608 投稿時間:2004年04月08日(Thu) 14:42 投稿者名: URL:

皆さんありがとうございます。まとめて返答します。

店主のピチューさん>よく分かりません・・・。
一応言うと、(モジュラーケーブル)~「モデム」~(無線)~「パソコン」です。

ぷららユーザーさん>抜いてみても出来ませんでした・・・。

ryujinさん>ログは「2004/04/08 14:26:31 219.19.138.115 GET http://***.***.***.***/」です。
エンコードというのがいまいち分かりませんでした・・・。思い当たるエンコードとしては、「日本語(シフト JIS)」です。


ipconfig

No.15609 投稿時間:2004年04月08日(Thu) 16:21 投稿者名:店主のピチュー URL:http://tenpichu.no-ip.com/

なるほど。
・・・んん???(ぇ

ちょっといいでしょうか、ipconfigなどを使い、PCに割り当てられているIPアドレスを見てください。
192.168.*.*の場合プライベートIPアドレスで、ADSLルータを使っていると思われます。

というより、流れからして・・・。

そして、そのADSLルータでは設定をしたのでしょうか?


一応しました。

No.15610 投稿時間:2004年04月08日(Thu) 17:03 投稿者名: URL:

一応しました。
もう1度設定を見てみようと思うんですが
部屋が離れていて、しかも有線でつながないと設定できない(一時PC移動)ので少々面倒・・・。
なので暇なときじゃないと出来ません。

LANケーブルを買う気はありません。


無線

No.15611 投稿時間:2004年04月08日(Thu) 18:47 投稿者名:店主のピチュー URL:http://tenpichu.no-ip.com/

結局無線だからつながらないというのも「ありえなくはない」です。
ためしに有線で接続してみてください。


ログにG-IPが残ってる・・・つながっているんじゃないかな

No.15616 投稿時間:2004年04月09日(Fri) 00:48 投稿者名:ryujin URL:http://ryujin.info/

これは、
・おやじさんの接続テストにてのWWWサーバテスト・ログ」でしょうか?
・自分のWebサーバーのログでしょうか?

>ログは「2004/04/08 14:26:31 219.19.138.115 GET http://***.***.***.***/」です。

「219.19.138.115」は、グローバルIPアドレスですね。
外部からつながっているんじゃないかな。

自分WEBろぐなら、
・おやじさんの接続テストにてのWWWサーバテストを再度行う
・おやじさんの接続テストの「ログ表示」する。
それを貼り付けして、提示願います。

それと、その時に
> エンコードというのがいまいち分かりませんでした・・・。思い当たるエンコードとしては、「日本語(シフト JIS)」です。
とは、「おやじさんの接続テストにてのWWWサーバテスト」にて、真っ白表示された時に
・ブラウザーの表示→エンコード→色々変更して試してみると言う事を試してみてください。


|目次|掲示板|過去ログ目次|▲頁先頭|