投稿日:2004年04月03日 作成鷹の巣

No.15453 [情報]PHP4.3.5にアップデートするとApacheがこける



[情報]PHP4.3.5にアップデートするとApacheがこける

No.15453 投稿時間:2004年04月03日(Sat) 04:33 投稿者名:APACHE URL:http://kemuri-net.dip.jp/~server/worm.txt

Windows環境で
PHP 4.3.5をインストールしてApacheのモジュールとして動作させると
1.3系ではApache起動に失敗し
2.0系ではApacheの停止及び再起動時にエラーを吐きます。
※Linux環境は未確認

これはPHP4.3.5リリース後まもなくでた
PHP 4.3.6RC1で修正されていますがRC版は正式リリース版ではないので
完全にPHPに依存したサイトやPHPを使って利用者の多いサイトを運営している場合
PHP4.3.6に更新せずPHP4.3.4を利用する事をおすすめします。
※コマンドラインから走らせても場合によってエラーを吐くためCGI版として使ってもどういう物かと思うため。


fedora core 1ではhttpd-2.0.49とphp-4.3.5で動いています。

No.15455 投稿時間:2004年04月03日(Sat) 07:22 投稿者名:stranger URL:

> Windows環境で
> PHP 4.3.5をインストールしてApacheのモジュールとして動作させると
> 1.3系ではApache起動に失敗し
> 2.0系ではApacheの停止及び再起動時にエラーを吐きます。
> ※Linux環境は未確認
> > これはPHP4.3.5リリース後まもなくでた
> PHP 4.3.6RC1で修正されていますがRC版は正式リリース版ではないので
> 完全にPHPに依存したサイトやPHPを使って利用者の多いサイトを運営している場合
> PHP4.3.6に更新せずPHP4.3.4を利用する事をおすすめします。
> ※コマンドラインから走らせても場合によってエラーを吐くためCGI版として使ってもどういう物かと思うため。
fedora core 1 では
httpd-2.0.49
php-4.3.5
で動いています
ただ、 curl-7.11.1をphpにリンクするとmakeでエラーがでます
curl-7.11.0だとOK


|目次|掲示板|過去ログ目次|▲頁先頭|