投稿日:2004年03月11日 作成鷹の巣

No.15139 Redhat Linuxを最新版に更新する方法は?



Redhat Linuxを最新版に更新する方法は?

No.15139 投稿時間:2004年03月11日(Thu) 18:28 投稿者名:ss URL:

はじめまして。投稿させていただきます。

現在RedhatのOSに対し、パッチを当てたいと思っています。
ですが、なにぶん初心者なもので方法がまったく分かりません。

ひとつづつrpmファイルを当てていくにも何を当てればよいのかが分からないですし、
up2dateとやらを使っても良いみたいなのですが方法も良く分かりません。

目的としてはネットワークの脆弱性をクリアしたいのですが・・・
何でも良いので情報頂ければと思います。

よろしくお願いいたします。


1つの方法。

No.15141 投稿時間:2004年03月11日(Thu) 22:02 投稿者名:stranger URL:

> はじめまして。投稿させていただきます。
> > 現在RedhatのOSに対し、パッチを当てたいと思っています。
> ですが、なにぶん初心者なもので方法がまったく分かりません。
> > ひとつづつrpmファイルを当てていくにも何を当てればよいのかが分からないですし、
> up2dateとやらを使っても良いみたいなのですが方法も良く分かりません。
> > 目的としてはネットワークの脆弱性をクリアしたいのですが・・・
> 何でも良いので情報頂ければと思います。
> > よろしくお願いいたします。

up2dateは四月以降はどうなるかわからないので
1つの方法
全てのパッチを一度に当てるには余りにも数が多いので
ひと月毎にディレクトリをつくりアップデートパッケージをダウンロードして保存します
そのディレクトリに移動して 管理者権限で
# rpm -Fvh *.rpm
と実行すれば インストールされているパッケージのみアップデートされます
気をつけること
警告がでるので気にかかるなら
/usr/share/rhnにあるRPM-GPG-KEYをインストールする
# rpm --import /usr/share/rhn/RPM-GPG-KEY
同じパッケージのアップデートが続けて出されることがあるので新しいほうだけダウンロードする
CPUに合わせてダウンロードする
最近のredhatならば /var/log/rpmpkgsに毎日インストールされたパッケージの
ログがとられているので参考にする

サポートの切れたredhatは下記のサイトであつかわれます
http://www.fedoralegacy.org/


pythonの更新時にfailed dependenciesのエラーが発生。

No.15151 投稿時間:2004年03月12日(Fri) 14:17 投稿者名:ss URL:

strangerさん返答ありがとうございます。

> up2dateは四月以降はどうなるかわからないので
> 1つの方法
> 全てのパッチを一度に当てるには余りにも数が多いので
> ひと月毎にディレクトリをつくりアップデートパッケージをダウンロードして保存します
> そのディレクトリに移動して 管理者権限で
> # rpm -Fvh *.rpm
> と実行すれば インストールされているパッケージのみアップデートされます
> 気をつけること
> 警告がでるので気にかかるなら
> /usr/share/rhnにあるRPM-GPG-KEYをインストールする
> # rpm --import /usr/share/rhn/RPM-GPG-KEY
> 同じパッケージのアップデートが続けて出されることがあるので新しいほうだけダウンロードする
> CPUに合わせてダウンロードする
> 最近のredhatならば /var/log/rpmpkgsに毎日インストールされたパッケージの
> ログがとられているので参考にする
>
> サポートの切れたredhatは下記のサイトであつかわれます
> http://www.fedoralegacy.org/

そうですね。早速フォルダを作成して少しづつ当てています。
さらに、どなたかご存知であったなら教えていただきたいのですが、
現在pythonのrpmを当てているときに下記のエラーが発生してしまいます。
# rpm -Fvh python-1.5.2-43.62.i386.rpm
error: failed dependencies:
tkinter < 1.5.2-43.62 conflicts with python-1.5.2-43.62
このエラーはいったいどのようなものなのでしょうか?

ファイル競合のエラーが発生しているのかと思い
オプションに"-Uvh"をつけて実行しても同様のエラーが発生してしまいます。

また、tkinter-1.5.2-43.62.i386.rpmを先に当てるのかと思い実行してみましたが、
python = 1.5.2-43.62 is needed by tkinter-1.5.2-43.62
と依存関係のエラーが発生してしまいます。

もしよろしければ回避策などありましたらよろしくお願いいたします。


依存関係のあるものは同時にアップデートされていると思う。

No.15153 投稿時間:2004年03月12日(Fri) 17:43 投稿者名:stranger URL:

> > そうですね。早速フォルダを作成して少しづつ当てています。
> さらに、どなたかご存知であったなら教えていただきたいのですが、
> 現在pythonのrpmを当てているときに下記のエラーが発生してしまいます。
> # rpm -Fvh python-1.5.2-43.62.i386.rpm
> error: failed dependencies:
> tkinter < 1.5.2-43.62 conflicts with python-1.5.2-43.62
> このエラーはいったいどのようなものなのでしょうか?
> > ファイル競合のエラーが発生しているのかと思い
> オプションに"-Uvh"をつけて実行しても同様のエラーが発生してしまいます。
> > また、tkinter-1.5.2-43.62.i386.rpmを先に当てるのかと思い実行してみましたが、
> python = 1.5.2-43.62 is needed by tkinter-1.5.2-43.62
> と依存関係のエラーが発生してしまいます。
> > もしよろしければ回避策などありましたらよろしくお願いいたします。

依存関係のあるものは同時にアップデートされていると思う
同時にアップデートすれば良い(または同じディレクトリにいれて # rpm -Fvh *.rpm)
# rpm -Fvh python-1.5.2-43.62.i386.rpm tkinter-1.5.2-43.62.i386.rpm


正常に動作しました。

No.15154 投稿時間:2004年03月12日(Fri) 18:08 投稿者名:ss URL:

strangerさん。本当に初歩的な質問に対し親切にご返答頂きありがとうございます。

> 依存関係のあるものは同時にアップデートされていると思う
> 同時にアップデートすれば良い(または同じディレクトリにいれて # rpm -Fvh *.rpm)
> # rpm -Fvh python-1.5.2-43.62.i386.rpm tkinter-1.5.2-43.62.i386.rpm

上記のように実行したら正常に動作しました。ありがとうございます。


|目次|掲示板|過去ログ目次|▲頁先頭|