投稿日:2004年03月09日 作成鷹の巣

No.15102 Windows XPのNetBIOS over TCP/IPを無効にすると、ワークグループのコンピュータが表示されない。



Windows XPのNetBIOS over TCP/IPを無効にすると、ワークグループのコンピュータが表示されない。

No.15102 投稿時間:2004年03月09日(Tue) 08:50 投稿者名:たろ URL:

はじめまして。自宅サーバを作るに当たりこのHPには大変お世話になっております。
困ったことがありまして是非質問したいのです。

今まですべて2000で使っていたのですがノートだけXPにしてみました。
ところがここの設定のNetBIOS over TCP/IP を無効にする
とワークグループのコンピュータが表示できません。

パソコンすべてを有効にすると見えるようになるのですが
セキュリティ上問題ないのでしょうか??

無効の状態では
XP機はインターネットはつながっていてPingも通ってます。
標準のファイヤーウォールも切ってるし、NETBEUIもいれてます。

これはどのような現象なのでしょうか??
NETBEUIが機能していないのでしょうか??

かなり途方に暮れています。
どなたかヒントいただけないでしょうか??


「Microsoftネットワーククライアント」と「Microsoftネットワーク共有サービス」 を有効にしていますか?

No.15107 投稿時間:2004年03月09日(Tue) 11:53 投稿者名:Reboot URL:

> ところがここの設定のNetBIOS over TCP/IP を無効にする
> とワークグループのコンピュータが表示できません。

NetBEUI のプロパティで、「Microsoft ネットワーククライアント」
「Microsoftネットワーク共有サービス」 を有効にしていますか?。
的外れの回答でしたらすみません。


ルータの DHCP 機能を使用して、NetBIOS over TCP/IPを規定値(F) にして上手く機能しています。

No.15116 投稿時間:2004年03月09日(Tue) 21:44 投稿者名:Reboot URL:

すみません、XPでは NetBEUI はインストールしていても
NetBEUI のプロパティは表示されないようですね。

参考になるかどうか分かりませんが、わたしはサーバ機以外で
LANを作っていまして、それらは皆ルータの DHCP 機能を
使用しているので、NetBIOS over TCP/IP を無効にするでなく
規定値(F) にして上手くLANが機能しています。


NetBIOS有効又は規定値にすると問題なく使用できるのですが、セキュリティが気になります。

No.15118 投稿時間:2004年03月09日(Tue) 23:17 投稿者名:たろ URL:

> すみません、XPでは NetBEUI はインストールしていても
> NetBEUI のプロパティは表示されないようですね。
>
> 参考になるかどうか分かりませんが、わたしはサーバ機以外で
> LANを作っていまして、それらは皆ルータの DHCP 機能を
> 使用しているので、NetBIOS over TCP/IP を無効にするでなく
> 規定値(F) にして上手くLANが機能しています。

レスありがとうございます。

NetBIOS有効又は規定値にすると問題なく使用できるのですが、
セキュリティが気になります。
今まで2000のみでやっていた時はNetBios無効とNETBEUIでできていたので
疑問に思ったのです。
NETBEUIが機能していないと言うことなんでしょうか??


規定値(F) は、DHCP 機能を使用している場合、NetBIOS over TCP/IPを無効にする設定が適用。

No.15119 投稿時間:2004年03月09日(Tue) 23:48 投稿者名:Reboot URL:

規定値(F) は DHCP 機能を使用している場合 NetBIOS over TCP/IP
を無効にするの設定が適用されるようなので、セキュリティーは
それほど心配ないのでは…。

DHCP の範囲を 192.168.0.2 ~ 10とかでなくて、
192.168.0.164 ~ 172 とかにしておけばもっと安心かな。

ポートナンバーとローカルIPをセットで固定している訳では
ないから、この設定なら心配はいらないと思いますが、どうなん
でしょう?。


ルータで、外部からアクセスできないよう、遮断するように設定されていれば問題ないとおもいます。

No.15121 投稿時間:2004年03月10日(Wed) 08:39 投稿者名:stranger URL:

> 規定値(F) は DHCP 機能を使用している場合の設定ですから
> セキュリティーはそれほど心配ないのでは。
> > DHCP の範囲を 192.168.0.2 ~ 10とかでなくて、
> 192.168.0.64 ~ 72 とかにしておけばもっと安心かな。
> > ポートナンバーとローカルIPをセットで固定している訳では
> ないから、この設定なら心配はいらないと思いますが、どうなん
> でしょう?。

ルータで
netbiosに使われるポート 137、138、139 windows2000で使われるポート 445、593
などに外部からアクセスできないよう、遮断するように設定されていれば問題ないとおもいます
ポートについては 個人で調査してください
ルータ設定でローカル側のIPアドレスにallを設定してあれば、IPアドレスは関係無しに
空いているポートで通信可能です


参考URL。

No.15122 投稿時間:2004年03月10日(Wed) 08:45 投稿者名:stranger URL:

XPでの正式なNETBEUIのサポートはなし
インストールの方法は下記のサイトなど
http://www.atmarkit.co.jp/fwin2k/win2ktips/209xpnetbeui/xpnetbeui.html


たろさんのLANの中に、プライベートアドレスを固定に設定しているPCはありませんか。

No.15123 投稿時間:2004年03月10日(Wed) 11:32 投稿者名:Reboot URL:

> XPでの正式なNETBEUIのサポートはなし

そうなんですよね。NetBEUIはもう過去の遺物のようで、
ルータを超えない範囲でのLANでのみ使ってもよいが
お薦めしないという解説が多いですね。

たろさんへ
前にも書きましたが、うちではLANのPCは皆ルータの DHCP 機能
を使用していまして、NetBIOS over TCP/IP を無効にするの設定でも
問題なくLANが機能しました。たろさんのLANの中に、ローカル
IPを固定設定しているPCはありませんか。その辺りが少し気にな
ります。

たろさんの書き込みでXPのLAN設定を見直してみました。
色々余計な設定に v が入れてあったようで、余分と思われる項目の
v を皆外してみたところ、「ネットワーク全体」の表示がとても早く
なりました。どうもです。


大変参考になりました。

No.15145 投稿時間:2004年03月12日(Fri) 01:46 投稿者名:たろ URL:

大変遅くなりまして申し訳ないです。
Rebootさんやstrangerさんのおっしゃるとおりにしたり
いろいろ試したりしておりました。
XPにZoneAlarm2.6をいれたところ調子がイマイチ(×_×)

Reboot様
おっしゃるとおりプライベートアドレスの中に固定しているIPのサーバーがあります。

stranger様
>ルータで
>netbiosに使われるポート 137、138、139 windows2000で使われるポート 445、593
>などに外部からアクセスできないよう、遮断するように設定されていれば問題ないとおもいます
>ポートについては 個人で調査してください
>ルータ設定でローカル側のIPアドレスにallを設定してあれば、IPアドレスは関係無しに
>空いているポートで通信可能です

なるほど。大変参考になりました。


Rebootさんやstrangerさん、貴重なご意見ありがとうございました。
連絡遅れて本当に申し訳ないです。


|目次|掲示板|過去ログ目次|▲頁先頭|