投稿日:2003年11月30日 作成鷹の巣

No.13711 1ヶ月前より、wwwサーバーに接続するまでに時間がかかる様になった。



1ヶ月前より、wwwサーバーに接続するまでに時間がかかる様になった。

No.13711 投稿時間:2003年11月30日(Sun) 13:31 投稿者名:nayuna URL:

wwwサーバー構築の時から、いつも参考にさせていただいております。
この度、予期せぬトラブルがあり、その解決に苦しんでおります。できれば皆様のお力をお借りしたく書き込みいたしました。

症状は、ここ一月前くらいより始まったようで、WAN側からwwwサーバーに繋ごうとすると、なかなか表示されないというものです。具体的には、問い合わせているような状態?(真っ白なページが表示されているような??後述のURLでご参照くださると助かります)が長く続いてしまいます。どうしても原因がわからないので、ご助言いただけると助かります。現在の環境とわかっている事は以下の通りです。
---------------------------------
「自宅サーバーの環境」
ADSL回線
富士通製ルーターモデム
RedHatLinux9 + Apache2
---------------------------------
「現在わかっている事や、やってみた事です」
・LAN内から呼び出すと、正常なスピードで表示される。
・LAN内からproxyを通して、呼び出すと、正常なスピードで表示される。
・外部から呼び出してみると、なかなか表示されない(症状)。
・自宅サーバーをハードを含めて一から構築し直したが、解消されなかった。
・LAN内のPCをすべて静的IPにしてルーターのDHCP機能を止めたが、解消されなかった。
・LAN内からのpingは正常に返ってくる。
・WAN側からのpingは正常に返ってくる。
WAN側からのpingは、鷹の巣さんのサイトの下記ページを利用させていただきました。
http://sakaguch.com/internetTest.html
---------------------------------
URL: http://www.bikeman.no-ip.org
↑文才がなく、うまく説明できていないと思いますので(^^;)、実際に症状をみてもらったほうが状況がわかりやすいかもしれません。すみません。

どうしても原因がわからないのです。いささか他力本願で情けないのですが、何か助言いただけると助かります。宜しくお願いいたします。尚、長文大変失礼いたしました。


逆引きの可能性

No.13714 投稿時間:2003年11月30日(Sun) 22:06 投稿者名:OAK URL:

ちょうど20秒ですね。何回行っても結果は同じ。どうも逆引きくさい。

/etc/resolv.conf と /etc/sysconfig/network は正しいでしょうか。
そのLinuxマシンからWEBが使えますか?
203.212.55.105 をLinuxサーバー機で逆引きして見てください。


各ファイルは以下のような記述になっていました。

No.13715 投稿時間:2003年12月01日(Mon) 00:04 投稿者名:nayuna URL:

さっそく御回答くださりありがとうございます。
宜しくお願い致します。

> /etc/resolv.conf と /etc/sysconfig/network は正しいでしょうか。
ごめんなさい(汗)、少し調べてみたのですが、まだまだ知識が足りず、これが正しいのかどうかもわかりませんでした。。。
各ファイルは以下のような記述になっていました。

----- /etc/resolv.conf ------
; generated by /sbin/dhclient-script
nameserver 192.168.0.1

----- /etc/sysconfig/network ------
NETWORKING=yes
HOSTNAME=linux.bikeman.no-ip.org

「/etc/resolv.conf」の1行目の記述は私には見覚えが無いです。
他は、私の設定した通りになっていると思いました。
どこか誤っている部分はありますでしょうか?
>追記
もしかして、この1行目には
domain bikeman.no-ip.org
を記述すべきなのでしょうか?

> 203.212.55.105 をLinuxサーバー機で逆引きして見てください。

以下のように出て来ました。
-----------------------------------------------------------------------
[root@linux root]# nslookup 203.212.55.105
Note: nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead. Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
Server: 192.168.0.1
Address: 192.168.0.1#53

Non-authoritative answer:
85.243.253.210.in-addr.arpa name = d243085.ppp.asahi-net.or.jp.

Authoritative answers can be found from:
243.253.210.in-addr.arpa nameserver = falcon.asahi-net.or.jp.
243.253.210.in-addr.arpa nameserver = crusader.asahi-net.or.jp.
falcon.asahi-net.or.jp internet address = 202.224.32.2
crusader.asahi-net.or.jp internet address = 202.224.39.8
------------------------------------------------------------------------
それから、ブラウザでやってみたら、鷹の巣自宅サーバーさんの404エラーのページが表示されました。

宜しくお願いいたします。


以前設定したDHCPが残っているようです

No.13716 投稿時間:2003年12月01日(Mon) 09:08 投稿者名:OAK URL:

> ----- /etc/resolv.conf ------
> ; generated by /sbin/dhclient-script
> nameserver 192.168.0.1

どうやらIPアドレスがDHCP取得になっているようです。

> ----- /etc/sysconfig/network ------
> NETWORKING=yes
> HOSTNAME=linux.bikeman.no-ip.org

これからも同じ事がいえます。

このファイルを直接直してもよいのですが、
まずネットワーク設定で、DHCPから取得を止めるのが良いでしょう
ネットワーク設定で、
DHCP取得なし。
IPアドレスは固定で割り当て
DNSサーバーはプロバイダーのDNSサーバーアドレス
(分からなければルーターでもかまわないです)
デフォルトゲートウェイはルーターアドレス
ときちっと設定し直してください。

/etc/resolv.conf は
nameserver xx.xx.xx.xx
nameserver xx.xx.xx.xx
とプロバイダーDNSが2つ入るのが正しい。(それ以外の項目がある事もあります)

/etc/sysconfig/network は
NETWORKING=yes
HOSTNAME=linux.bikeman.no-ip.org
のほかに
GATEWAY=192.168.0.1
GATEWAYDEV=eth0
などが入ってくればOKです。

> 「/etc/resolv.conf」の1行目の記述は私には見覚えが無いです。
これはDHCPクライアントが動作して書き換えています。

> domain bikeman.no-ip.org
> を記述すべきなのでしょうか?

記述してもかまいませんが特に必要ではありません

> > 203.212.55.105 をLinuxサーバー機で逆引きして見てください。

2~3秒ででてくれば逆引きは大丈夫です。

> それから、ブラウザでやってみたら、鷹の巣自宅サーバーさんの404エラーのページが表示されました。

たぶんGWが不明なのではと思います。
ネットワーク再設定して、リブートしたらもう一度上記項目を再点検してください。


設定してみました。

No.13720 投稿時間:2003年12月01日(Mon) 14:45 投稿者名:nayuna URL:http://www.bikeman.no-ip.org

OAKさん的確なアドバイスをありがとうございます。
教えて頂いたことを参考に、以下のように調整してみました。


> どうやらIPアドレスがDHCP取得になっているようです。
「ネットワークの設定」をもう一度設定し直してみたのですがGUI環境で設定したせいか、何故か「/etc/sysconfig/network」のGATEWAYとGATEWAYDEVに反映されなかったようでしたので、以下のように直接編集してみました。それと、DNSのところにはプロバイダーの物を先に、2番目にルーターのアドレスを書いておきました。何かさらなる間違えがございましたら、ご指摘よろしくお願い致します。

----- /etc/resolv.conf -----
domain bikeman.no-ip.org
nameserver 202.238.95.26
nameserver 192.168.0.1

----- /etc/sysconfig/network -----
NETWORKING=yes
HOSTNAME=linux.bikeman.no-ip.org
GATEWAY=192.168.0.1
GATEWAYDEV=eth0

あと、固定IPの方法で再度インターネットを検索してみたら、「/etc/sysconfig/network-scripts/ifcfg-eth0」の記述が載っていたので確認してみたところ、こちらは大丈夫そうでした。
(BOOTPROTO=none IPADDR=192.168.0.86 と指定した通りになっていました。)

> 2~3秒ででてくれば逆引きは大丈夫です。
シェルからnslookupとwhoisを試してみたら、次のものが打ち込んですぐに逆引きできました。
85.243.253.210.in-addr.arpa name = d243085.ppp.asahi-net.or.
ブラウザからは相変わらず404エラーでした。


それから、また新しい質問になってしまうんですが。。。
この作業をしていて感じたのですが、LAN内からでもこの度の症状が改善したかどうかを確かめられるいい方法は、何かないものでしょうか?なんだか、そのつど外の方に確認してもらうのも御迷惑かと思いましたので。。。(^^;)
宜しくお願い致します。


----------追記--------------
先ほど、ルーターのファームウェアのバージョンなどの確認で、接続会社のHPを確認したところ、プロトコルがPPPoAのところを、PPPoEと設定のミスをしていたことがわかりました(汗)!普通にインターネットにつながってはいたのですが、これも原因の一つかもしれないと思い報告です。ああ、単純なミスを。。。(泣)


ブラウザが動かない理由がみあたりません

No.13722 投稿時間:2003年12月01日(Mon) 18:41 投稿者名:OAK URL:

20秒かかるというトラブルは解決したとみて良いのですね。

-- /etc/resolv.conf -----
domain bikeman.no-ip.org
nameserver 202.238.95.26
nameserver 192.168.0.1

問題はありません。
search bikeman.no-ip.org
も追加するのが正式かな。(独自ドメイン等ない状態では必要ありません)

> ----- /etc/sysconfig/network -----
> NETWORKING=yes
> HOSTNAME=linux.bikeman.no-ip.org
> GATEWAY=192.168.0.1
> GATEWAYDEV=eth0

ここも大丈夫。(正式には HOSTNAME=linux ですが動作には関係ありません)

>「/etc/sysconfig/network-scripts/ifcfg-eth0」の記述が載っていたので確認してみたところ、こちらは大丈夫そうでした。
> (BOOTPROTO=none IPADDR=192.168.0.86 と指定した通りになっていました。)

そこもOK

> シェルからnslookupとwhoisを試してみたら、次のものが打ち込んですぐに逆引きできました。
> 85.243.253.210.in-addr.arpa name = d243085.ppp.asahi-net.or.

nslookup でなく host で行なうのが今のやり方のようです。
$ host 203.212.55.105
85.243.253.210.in-addr.arpa domain name pointer d243085.ppp.asahi-net.or.jp.

whois だと
$ whois 203.212.55.105 | grep NS
NS2.SAKAGUCH.COM
NS1.SAKAGUCH.COM

と引けると思います。

> ブラウザからは相変わらず404エラーでした。

ここは問題ありです。原因が思いつかない。

$ cd /tmp
$ wget http://sakaguch.com/

--18:35:28-- http://sakaguch.com/
=> `index.html'
Connecting to sakaguch.com:80... connected!
HTTP request sent, awaiting response... 200 Document follows
Length: unspecified [text/html]
0K -> .......... ......
18:35:30 (9.40 KB/s) - `index.html' saved [16866]
などと出ませんか?

> それから、また新しい質問になってしまうんですが。。。
> この作業をしていて感じたのですが、LAN内からでもこの度の症状が改善したかどうかを確かめられるいい方法は、何かないものでしょうか?なんだか、そのつど外の方に確認してもらうのも御迷惑かと思いましたので。。。(^^;)

私のサイトや「おやじさん」のところに簡単なプロキシがあります。
おやじさんのサイトの方が見れる制限は少ないと思います。

> ----------追記--------------
> 先ほど、ルーターのファームウェアのバージョンなどの確認で、接続会社のHPを確認したところ、プロトコルがPPPoAのところを、PPPoEと設定のミスをしていたことがわかりました(汗)!普通にインターネットにつながってはいたのですが、これも原因の一つかもしれないと思い報告です。ああ、単純なミスを。。。(泣)

接続できているなら問題は無いはずですがPPPOAは知らないのでコメントしません。


解決したとの報告がありました!

No.13723 投稿時間:2003年12月01日(Mon) 20:25 投稿者名:nayuna URL:http://www.bikeman.no-ip.org

> 20秒かかるというトラブルは解決したとみて良いのですね。
先程掲示板に、観覧していた方から、表示速度の問題が解決しているとの報告が上がって来ました!よかったー(^^;)

> search bikeman.no-ip.org
> HOSTNAME=linux
ご指摘ありがとうございます。このあと正式な形に書き直しておこうと思います。

> $ wget http://sakaguch.com/
この方法だと、問題なくできました。鷹の巣さんのHPのインデックスページが保存されました。
逆びきというもの自体が理解できていないので、私のやり方がマズイのかもしれません。
この辺りをもう少し勉強してみて、それでも改善できなかったら、またこちらにご質問に上がろうかと思います。

> 私のサイトや「おやじさん」のところに簡単なプロキシがあります。
ありがとうございます。早速利用させて頂きました。
ぜひ今後もまた利用させて頂きたいです。宜しくお願い致します。

> PPPOA
影響していたのかは、良く分かりませんでしたが、今後試験的に変えてみたりして影響を試してみることにします。


とりあえず、直面していた大きな問題は無事解決できたことになると思います(^^)。
本当に助かりました。OAKさんには、お忙しい中で手とり足とり教えて頂いて、本当に感謝しております。同時に、自分の知識が足りないということも痛感できましたので(汗)これをきっかけに、もっといろいろと理解していかなくてはと思いました。
ブラウザの件も、もう少し自分でも勉強して、指摘されている事の意味だけでもだいたい理解できるようになってから、また改めてこちらに投稿させて頂こうと思います。
本当にありがとうございました。


|目次|掲示板|過去ログ目次|▲頁先頭|