投稿日:2003年11月19日 作成鷹の巣

No.13522 ブラウザのIEでアクセスすると、Bad Requestが出て掲示板が見れない。



ブラウザのIEでアクセスすると、Bad Requestが出て掲示板が見れない。

No.13522 投稿時間:2003年11月19日(Wed) 19:15 投稿者名:まさ URL:

こんばんは、どうぞよろしくお願いいたします。

Vine2.6R1で運用をはじめておりますが、利用者からBad Requestがでて掲示板が見れないとの連絡を多々受けます。
しかし私自身にはそのようなことは出たことが無く、別の媒体を利用しても出たことはありません。
色々と調べてみたのですが対策が見つかりません。 またクライアント側のエラーであることはわかったのですが、何故出るのかと言うのがはっきりしません。
サーバーの設定に問題があるのでしょうか?

ちなみにブラウザをIE以外にしたら問題なく表示されるらしいのですが・・・。
何卒対策や情報などのご提供お願いいたします。


これだけの情報だと何とも言えない。

No.13525 投稿時間:2003年11月19日(Wed) 22:00 投稿者名:APACHE URL:http://kemuri-net.dip.jp/~server/

> ちなみにブラウザをIE以外にしたら問題なく表示されるらしいのですが・・・。
> 何卒対策や情報などのご提供お願いいたします。
これだけの情報だと何とも言えない様な…


400エラーでアクセスできないようなのです。

No.13534 投稿時間:2003年11月20日(Thu) 08:37 投稿者名:まさ URL:

こんにちは、お返事どうもありがとうございます。

自分でも何なのかよくわからない面が多々ありましたので、曖昧な質問になってしまいました。
申し訳ないです。

まず状況なんですが
CGI用としてサーバーを稼動させており、利用の全てがCGIです。
で、私のサイトからそのサーバー(CGI)にリンクさせているのですが、この掲示板を表示させると
どれくらいの人数なのかはわかりませんが、400エラーでアクセスできないようなのです。
アクセスログにも同様の400を返すログが多数残っておりました。
私自身は400エラーが出た事は無いのですが、下記URLにおいてはクライアントの問題との記載がされているので
http://www.nda.co.jp/memo/RFC2068.html

サーバーに問題があるのか、本当にクライアントの問題なのか、もしくは掲示板かと言ったところで結論が出ない状態なのです。
ちなみに使用している掲示板は下記のものであります。
http://www.skullysoft.com/

そして今まで暫定的に対応してきたのが、ブラウザのcookie削除です(これはネットで検索して調べました)
cookie削除で見れるようにはなるのですが、最近になってcookieを削除しても見ることが出来ない人も出てきております。

上記の情報で何かしらの対策等見つけることは出来ますでしょうか?
この情報があったらというのがあれば、記載いたしますのでご協力の程どうぞよろしくお願いいたします。


httpd に来るリクエストヘッダの内容を逐一調べ上げるしか無いように思えます。

No.13536 投稿時間:2003年11月20日(Thu) 11:08 投稿者名:通行人 URL:

> 私自身は400エラーが出た事は無いのですが、下記URLにおいてはクライアントの問題との記載がされているので
> http://www.nda.co.jp/memo/RFC2068.html

あくまで「その HTTP リクエストの構文に、問題があった」というだけです。
原因は、サーバが出力したフォームやスクリプト等 (クッキー操作も含め) である可能性もあります。

サーバが 400 を返している限り (= CGI に処理が渡され、その出力として 400 が出てきた、という訳ではない)、リクエストに何か問題があると思います。
気の遠くなるような話ですが、httpd に来るリクエストヘッダの内容を逐一調べ上げるしか無いように思えます。


|目次|掲示板|過去ログ目次|▲頁先頭|