投稿日:2003年11月09日 作成鷹の巣

No.13356 フォームメール(postmail)が送信できない。



フォームメール(postmail)が送信できない。

No.13356 投稿時間:2003年11月09日(Sun) 21:35 投稿者名:paleblue URL:

このページだけを頼りにWWW FTP Mailサーバを立ち上げました 問題なく動作し大変ありがたく思っております。 ただひとつだけ
CGIでメールフォームが動作しません。 AN HTTPD, ArGoSoft_mailserver, sendmane.exe postmailの組み合わせです。 sendmaneの
単体送信テストは問題ないです。 メールフォームでわざとメールアドレスを入れずに送信ボタンを押すとメールアドレスが入力されていない旨メッセージが出ますのでpostmail.cgiは正常に動作していると思うのですが。 http://......../postmail.cgi?mode=check を行うとERROR ! 不正なアクセスです と表示されます。 フォームにすべてを入力して確認画面のあと送信ボタンを押すと (http://127.0.0.1/cgi/postmail/postmail.cgi で) ページを表示できません と表示されます. メールフォームを正常に
動作させるため なにか解決のヒントはありませんでしょうか?


mimew.pl はちゃんと入れてますか?

No.13358 投稿時間:2003年11月09日(Sun) 23:03 投稿者名:magenohara URL:

私はFreeBSDで動かしてましたが、
mimew.pl はちゃんと入れてますか?
私もPostMail使ってて、mimew.plを入れ忘れたばっかりに同じようなエラーが出たんです。


mimew.pl で解決しました!

No.13365 投稿時間:2003年11月10日(Mon) 11:07 投稿者名:paleblue URL:

magenoharaさま
ありがとうございます 解決しました!

mimew.plは入れていましたが方法を間違えていたようです

http://www.cc.rim.or.jp/~ikuta/mime_pls/download.html からtar+gzip形式 mime_pls202.tgz(14,292バイト)
をダウンロードしてpostmail.cgiのフォルダに入れていたのですが、なにぶん初心者ですので tar+gzipの
解凍方法を間違えていたようです。 再度、別途解凍ソフトで解凍しmimew.plを再度入れてみたところ
完全に動作しました。 これで1週間の苦労が報われました。

どうもありがとうございます


追伸

No.13359 投稿時間:2003年11月09日(Sun) 23:07 投稿者名:magenohara URL:

mimew.plが入っていれば以下のような確認が出るはずです。(下記は私のサイト)
http://mar.ath.cx/~yoshihiro/user/postmail.cgi


とりあえず、URLから postmail.cgiを抜いてアクセスして、何もいれずに送信ボタンを押してみてください。

No.13360 投稿時間:2003年11月09日(Sun) 23:10 投稿者名:magenohara URL:

掲示板汚してすみません。
ただアクセスしただけではCGIに情報が渡っていないのでエラーになるだけです。
とりあえずURLから postmail.cgi を抜いてアクセスして、
何もいれずに送信ボタンを押してみてください。
確認画面が出るはずです。


postmail.cgiはWindows用ではないので、チェックモードをコメントアウト。

No.13361 投稿時間:2003年11月10日(Mon) 00:05 投稿者名:eternally URL:http://eternally.ddo.jp

> このページだけを頼りにWWW FTP Mailサーバを立ち上げました 問題なく動作し大変ありがたく思っております。 ただひとつだけ
> CGIでメールフォームが動作しません。 AN HTTPD, ArGoSoft_mailserver, sendmane.exe postmailの組み合わせです。 sendmaneの
> 単体送信テストは問題ないです。 メールフォームでわざとメールアドレスを入れずに送信ボタンを押すとメールアドレスが入力されていない旨メッセージが出ますのでpostmail.cgiは正常に動作していると思うのですが。 http://......../postmail.cgi?mode=check を行うとERROR ! 不正なアクセスです と表示されます。 フォームにすべてを入力して確認画面のあと送信ボタンを押すと (http://127.0.0.1/cgi/postmail/postmail.cgi で) ページを表示できません と表示されます. メールフォームを正常に
> 動作させるため なにか解決のヒントはありませんでしょうか?
たしか、postmail.cgiはWindows用ではないのでチェックモードのところをコメントアウトしなくてはいけなかったはずです。
でもこのサイトを見ながらやったならしてあるはずですよね・・・。
お力になれそうにありません、すいません。


チェックははずしています。

No.13364 投稿時間:2003年11月10日(Mon) 10:08 投稿者名:paleblue URL:

> たしか、postmail.cgiはWindows用ではないのでチェックモードのところをコメントアウトしなくてはいけなかったはずです。
> でもこのサイトを見ながらやったならしてあるはずですよね・・・。
> お力になれそうにありません、すいません。

eternallyさま メールありがとうございます
はい、'鷹ノ巣'さんの指示にあるとおりチェックははずしています
なにぶん全く知識がないものですから、もし何か思い当たることがございましたらなんでも結構ですので
またご教示くださいませ

ありがとうございます


|目次|掲示板|過去ログ目次|▲頁先頭|