投稿日:2003年10月29日 作成鷹の巣

No.13141 Yahoo!BBで自宅サーバー構築にチャレンジして、うまくいきません。



Yahoo!BBで自宅サーバー構築にチャレンジして、うまくいきません。

No.13141 投稿時間:2003年10月29日(Wed) 23:26 投稿者名:nori URL:

こんばんは、はじめまして。

この度自宅サーバー構築にチャレンジしてみたのですが、
うまくいきません。
何かアドバイスが頂ければと思い投稿させて頂きました。
よろしくお願い致します。

環境等は以下のようになっています。
ルータに2台のPCがあり、
PC1の方をwebサーバーにしようと考えています。
サーバーのポート番号は80番で設定しています。
ルータにはポート番号80番の
アドレス変換"グローバルIP→192.168.11.3"
の設定を行っています。

PC2からhttp://192.168.11.3/でアクセスすると
問題無く表示されますが、グローバルIPでアクセスすると
「HTTP 400 - 正しくない要求」となってしまいます。
PC2からグローバルIPへのpingは通ります。

Yahoo!BBでは80番が閉じられているという話もあるようですが
Sygateのスキャン結果では80番はOPENになっていましたので、
80番を使用しています。
(ちなみに8080、8000でも試してみましたが結果は同じでした)
あと、ウイルスバスター2004のFWは無効にしてみましたが、
結果は変わらず駄目でした。
SMTP、FTPはまだ使用していないので設定していません。

「環境等」
業者:Yahoo!BB(IP非固定)
接続:YahooBBモデム→ルーター(メルコ:WBR-B11)192.168.11.1
→PC1(WINXP)192.168.11.3固定
→PC2(WIN2000)192.168.11.4固定
サーバーソフト:AN HTTPD1.42k(PC1にインストール)
ファイヤーウォール:ウイルスバスター2004


No.13144と同じです。

No.13156 投稿時間:2003年10月30日(Thu) 20:59 投稿者名:おやじ URL:http://www.aconus.com/~oyaji/

こんばんは。

> PC2からhttp://192.168.11.3/でアクセスすると
> 問題無く表示されますが、グローバルIPでアクセスすると
> 「HTTP 400 - 正しくない要求」となってしまいます。
> PC2からグローバルIPへのpingは通ります。

ルータの仕様です。ルータの設定認証画面がでる(ルータのHTTPDが応答)するタイプと無視する
タイプがあり、noriさんのは後者のタイプです。
pingは通るのが普通です。


外部PCからの確認を試してみようと思います。

No.13160 投稿時間:2003年10月31日(Fri) 01:31 投稿者名:nori URL:

おやじさん。こんばんは、ありがとうございました。

外部PCからの確認を試してみようと思います。
本当にありがとうございました。

> こんばんは。
>
> > PC2からhttp://192.168.11.3/でアクセスすると
> > 問題無く表示されますが、グローバルIPでアクセスすると
> > 「HTTP 400 - 正しくない要求」となってしまいます。
> > PC2からグローバルIPへのpingは通ります。
>
> ルータの仕様です。ルータの設定認証画面がでる(ルータのHTTPDが応答)するタイプと無視する
> タイプがあり、noriさんのは後者のタイプです。
> pingは通るのが普通です。


|目次|掲示板|過去ログ目次|▲頁先頭|