投稿日:2003年10月28日 作成鷹の巣

No.13107 サーバーのResponse timeが遅すぎます。解決法はないでしょうか?



サーバーのResponse timeが遅すぎます。解決法はないでしょうか?

No.13107 投稿時間:2003年10月28日(Tue) 02:44 投稿者名:もこし URL:http://asobigokoro.com/

はじめまして、鷹の巣さまのページにはいつもお世話になっております。
以前、WindowsXPでサーバーをたてていましたがこの度ついにRedHatLinux9を導入し、何とか運営し始めました。
しかし、どうも様子がおかしいのです。
知り合いから「ページが重くなった」とか、見れないなどの苦情を多く受けましたのでチェックしてみましたら
確かに重いです。ダイナミックDNSの変換はとても反応がいいのですが、IPアドレスを直接入れるとResponse timeは20秒前後かかってしまいます。ということはサーバの応答が遅いとしか思えません。内側からのアクセスは遅めですがそこまでではないようです。
特定の人からのアクセスが特に遅いようにも思えます。
CPUはCerelon500Mhz、メモリ256MBで、プロバイダはヤフー、アイオーデータのルータを介しております。
サーバの応答を速くするにはどうしたらよいのでしょうか?

どうか、ご教授お願いいたします。


サーバー応答の調整について。

No.13108 投稿時間:2003年10月28日(Tue) 02:59 投稿者名:まさ URL:

Linuxの参考になるのか不明ですが当方はWinXPで回線
もADSLで上り600Kbit/sで非公開のHPですのでトラ
ヒックはたいしたことはありません。
チューニングとしてCPUは2GHZ メモリ1Gbyteとし更に
WinXPのレジストリの2次キャッシュ・メモリを512Mbyteに
設定したところ同時複数アクセス数については未検証です
が単独でのレスポンスはかなり向上した感じです。この辺
は関連サイトで情報を収集いたしました。


遅くなる理由の1つに逆引きの可能性があります。

No.13110 投稿時間:2003年10月28日(Tue) 09:03 投稿者名:OAK URL:

> Linuxの参考になるのか不明ですが当方はWinXPで回線
> もADSLで上り600Kbit/sで非公開のHPですのでトラ
> ヒックはたいしたことはありません。
> チューニングとしてCPUは2GHZ メモリ1Gbyteとし更に
> WinXPのレジストリの2次キャッシュ・メモリを512Mbyteに
> 設定したところ同時複数アクセス数については未検証です
> が単独でのレスポンスはかなり向上した感じです。この辺
> は関連サイトで情報を収集いたしました。

P2の233Mで64Mメモリーでやっている私へのあてつけかな。(笑)
簡単なHTMLで20秒と言う話ではないと思いますが。

まず設定確認を。
遅くなる理由の1つに逆引きの可能性があります。
/etc/resolv.confのnameserverにプロバイダーのdnsが正しく入っていますか
そのDNSは信頼できますか。余計なDNSがかかれていませんか
ログはドメイン表示ならそれを止めてみる。route はどうですか
サーバーはDHCPでアドレスを取るなどしていないでしょうね
サーバーからモジラなどで外の他のホームページを見るとき遅くないですか


ご容赦ねがいます。

No.13111 投稿時間:2003年10月28日(Tue) 09:10 投稿者名:まさ URL:

> P2の233Mで64Mメモリーでやっている私へのあてつけかな。(笑)
とんでもございません、素人の薄学でご容赦ねがいます。


DNSが原因なら、DNSを立てる事を勧めます。

No.13112 投稿時間:2003年10月28日(Tue) 09:31 投稿者名:OAK URL:

> > P2の233Mで64Mメモリーでやっている私へのあてつけかな。(笑)
> とんでもございません、素人の薄学でご容赦ねがいます。

冗談ですから聞き流してください。

YBBのDNSはあまり良くない話は結構あります。
host 210.171.164.25
あるいは
nslookup 210.171.164.25
と実行すると
25.164.171.210.in-addr.arpa domain name pointer 164-25.parknet.ne.jp.
と通常1~2秒程度ででるのですが、時間がかかるようならDNSサーバーを立てる事を勧めます


ご教授の方法でチェックしてみましたが、1~2秒で表示されるようです。

No.13113 投稿時間:2003年10月28日(Tue) 10:49 投稿者名:もこし URL:http://asobigokoro.com/

> > > P2の233Mで64Mメモリーでやっている私へのあてつけかな。(笑)
> > とんでもございません、素人の薄学でご容赦ねがいます。
>
> 冗談ですから聞き流してください。
>
> YBBのDNSはあまり良くない話は結構あります。
> host 210.171.164.25
> あるいは
> nslookup 210.171.164.25
> と実行すると
> 25.164.171.210.in-addr.arpa domain name pointer 164-25.parknet.ne.jp.
> と通常1~2秒程度ででるのですが、時間がかかるようならDNSサーバーを立てる事を勧めます

早速のご教授ありがとうございます!
上記の方法でチェックしてみましたが、1~2秒で表示されるようです。


>まず設定確認を。
>遅くなる理由の1つに逆引きの可能性があります。
>/etc/resolv.confのnameserverにプロバイダーのdnsが正しく入っていますか
入っています。

>そのDNSは信頼できますか。余計なDNSがかかれていませんか
ないようです。

>ログはドメイン表示ならそれを止めてみる。route はどうですか
ログのドメイン表示を止めるというのはどこで設定するのでしょうか?routeとは?初心者の質問で恐れ入ります。

>サーバーはDHCPでアドレスを取るなどしていないでしょうね
手動で指定しています。

>サーバーからモジラなどで外の他のホームページを見るとき遅くないですか
遅くないです。サーバー機からhttp://127.0.0.1/でアクセスするときも応答が多少遅れます。

最近一度再起動したのですが、それ以来sshdや、httpdの応答が遅くなったように思えます。
なにか大事なサービスが稼動していないなどの原因も考えられるのでしょうか?


原因わからず

No.13122 投稿時間:2003年10月28日(Tue) 21:03 投稿者名:OAK URL:

> 最近一度再起動したのですが、それ以来sshdや、httpdの応答が遅くなったように思えます。
> なにか大事なサービスが稼動していないなどの原因も考えられるのでしょうか?

初心者と名乗る方にはレスしたくありませんが、
逆引きは大丈夫なようです。ホームページを見て来ました。
単純なHTMLとイメージでたいしたデーター量では無い見たいだし思いつく所がありません
どこかで聞いた話だなと思い探したら
http://www.aconus.com/~oyaji/bbs/wforum.cgi?mode=allread&no=1794&page=0
と同じですね。こちらも原因不明
DNSもISPも違う同じなのはredhatの最新版程度でしょうか。

イメージ単独でとっても20秒程度のタイムラグがあります。転送速度は500Kbps以上でていますので
回線の問題は無いでしょう。
ルータのせいなのかredhatのためかhttpの設定なのか。
ルータをはずせるなら試してみるのも手だと。
inetdから動かしているなら直接動かして見てください。


追記

No.13128 投稿時間:2003年10月29日(Wed) 09:07 投稿者名:OAK URL:

もしapacheを入れ直せるなら 1.3 を
もしOSを入れ直せるなら Vine Linux を
入れて見てください。


サーバ自身は遅延していませんか?

No.13140 投稿時間:2003年10月29日(Wed) 23:13 投稿者名:帯鯖 URL:

帯鯖@名古屋です。

> >サーバーからモジラなどで外の他のホームページを見るとき遅くないですか
> 遅くないです。サーバー機からhttp://127.0.0.1/でアクセスするときも応答が多少遅れます。

この記述について、もう少し詳しく教えて欲しいです。

1. サーバ機自身から http://127.0.0.1/ でアクセスした場合の応答時間は、
外部から問い合わせたときと比べて、どれくらい差がありますか?

ほぼイコールでしたら、遅延の原因はサーバ自身ですね。
他のプロセスがリソースを占有していませんか?

トロイやらウイルス系やらが大量にパケットを送受信していることはありませんよね?


2. LAN 内の他マシンからアクセスした場合の応答時間はどれくらいですか?

サーバ機自身での応答時間 << LAN 内マシンでの応答時間 でしたら、
それこそ過大パケットの可能性か、もしくは NIC に異常が発生している可能性があります。


原因と思われる箇所を、ひとつずつ潰していきましょう。


サーバ機のIPアドレスをルータのDHCPサーバが使用するIPアドレス以外に設定して解決。

No.13177 投稿時間:2003年11月01日(Sat) 10:37 投稿者名:もこし URL:

たくさんのレスありがとうございます。
いろいろやってみましたところ、何とか解決することが出来たようです。

サーバー機のLAN内固定IPをルータのDHCPサーバ機能で振り分ける範囲内に指定していたのが原因のように思えました。
振り分け範囲外に指定しましたら一秒ほどでレスポンスがあるようになりました。

ありがとうございました!


|目次|掲示板|過去ログ目次|▲頁先頭|