投稿日:2003年10月10日 作成鷹の巣

No.12785 外部から、自宅wwwサーバーへアクセスすると、Server Status:401 Unauthorizedとなり、公開出来ない。



外部から、自宅wwwサーバーへアクセスすると、Server Status:401 Unauthorizedとなり、公開出来ない。

No.12785 投稿時間:2003年10月10日(Fri) 00:25 投稿者名:8080 URL:

はじめまして。今回初めて投稿します。

こちらのHPを見まして、wwwサーバーの立ち上げを行っております。
が、どうしてもうまく公開できません。
【問題点】
プライベートIPアドレスでの表示は問題ありませんが、グローバルIP
アドレスで表示させようとすると、httpdでユーザー認証を有効にしていない
にもかかわらず、「ネットワークパスワードの入力」が表示され、パスを要求してきます。

【確認事項】
1.いったんユーザー認証を有効にし、ユーザー名、パスワードを設定し
ログインを行ったが、ログインできず。
2.インターネットセキュリティーを無効にしてもログイン画面が表示され、
やはりログインできず。
3.websitetestを行いましたが、Server Status欄に200ではなく、401とでます。
URL tested: http://xxx.xxx.xxx.xx/
Status: HTTP Responce - Unauthorized
Server Status: HTTP/1.0 401 Unauthorized
Response time: 0.3473 seconds

4. ポート80は間違いなく開いています。

【使用環境】
windows2000
IE6
AN HTTP DAEMONv1.42k

いったい何が間違っているのでしょうか…
どこの設定が間違っているのか現段階で自分では探すことができません。
既出の質問でしたら申し訳ありませんが、もしおわかりになる方が
いらっしゃいましたら、お教え願えませんでしょうか。

ちなみにFTPサーバーは問題なく動作しております。


ルータの設定画面では?

No.12786 投稿時間:2003年10月10日(Fri) 00:50 投稿者名:カイ URL:http://yaguma.com

> グローバルIP
> アドレスで表示させようとすると、httpdでユーザー認証を有効にしていない
> にもかかわらず、「ネットワークパスワードの入力」が表示され、パスを要求してきます。
>
やはりルータの設定画面ですかね?
サーバとして常時電源を入れているのならURLを公開してみてはどうでしょう.


ルーターの設定を見直してみます。

No.12791 投稿時間:2003年10月10日(Fri) 07:16 投稿者名:8080 URL:

カイさん、お返事ありがとうございます。
今日帰ったら、ルーターの設定を見直してみます。
とりあえず、アドレスです。
http://218.47.127.229/


解決しました!

No.12810 投稿時間:2003年10月11日(Sat) 17:13 投稿者名:8080 URL:

やはりカイさんのいうとおり、ルーターの設定が間違ってました。
結局、80番ポートがしっかりと開いていませんでした…。
私はNTT-ME MN7530というルーターを使っているのですが、
ポートを空ける設定が2箇所あって、
ポートフォワーディングとフィルタリングの両方を空けなければいけませんでした。
(これって常識なんですかね…それとも、このルーターだからなのでしょうか??)

カイさんありがとうございました!


|目次|掲示板|過去ログ目次|▲頁先頭|