投稿日:2003年07月19日 作成鷹の巣

No.11246 ルータ配下のWebサーバーに外部からのアクセスだけが出来ない。



ルータ配下のWebサーバーに外部からのアクセスだけが出来ない。

No.11246 投稿時間:2003年07月19日(Sat) 12:32 投稿者名:影の支配者 URL:

わからなくなり、ここに書き込みさせていただきます。
多分大体はできたんと思いますが、なぜか外部からのアクセスはできないのです。
OSはウィンドウズ2000です。
http://127.0.0.1/にアクセスすればちゃんとなります。
ルータの設定などが問題だと思いますが、よくわかりません。
ルータの名前は
BroadStation Settings
このような画面です。
http://buffalo.melcoinc.co.jp/pronow/blr3-tx4/demo/
ここからドメイン取得してます。
http://ieserver.net/

よくわかりませんが、リモートアドレスのポートが80になればいいのでしょうか?
それともPCのIPアドレスにアクセスすればいいのでしょうか?
ちなみにドメインのIPアドレスはリモートアドレスになっております。
下の3行はよくわからないので質問の仕方が変かもしれませんが、よろしくお願いします。


サーバー機のIPアドレス登録しましたか?

No.11252 投稿時間:2003年07月19日(Sat) 14:30 投稿者名:eternally URL:

http://buffalo.melcoinc.co.jp/pronow/blr3-tx4/demo/g6/frame.html
にサーバーのIPアドレス登録しましたか?

1.「プロトコル」→「アプリケーション」を選択
2.「LAN側IPアドレス」→「手動設定」その下にサーバーのIPアドレスを入力
3.「アドレス変換テーブルに追加」をクリック。

外部からの確認はどうやりましたか?
メルコのルータ(すべてそうかは知りませんが)LAN側からグローバルIPアドレスでアクセスしてもルータの設定画面が出るようになっています。(BLR2-TX4,BLR-TX4Mは持っているため確認済み。)
外部から見るときはhttp://www.anonymizer.com/などを使うのがよいかと。
携帯でもできますね。


外部からチェックしました。

No.11255 投稿時間:2003年07月19日(Sat) 15:56 投稿者名:影の支配者 URL:

> http://buffalo.melcoinc.co.jp/pronow/blr3-tx4/demo/g6/frame.html
> にサーバーのIPアドレス登録しましたか?
>
> 1.「プロトコル」→「アプリケーション」を選択
> 2.「LAN側IPアドレス」→「手動設定」その下にサーバーのIPアドレスを入力
> 3.「アドレス変換テーブルに追加」をクリック。
> はいちゃんとしてあると思います。
> 外部からの確認はどうやりましたか?
> メルコのルータ(すべてそうかは知りませんが)LAN側からグローバルIPアドレスでアクセスしてもルータの設定画面が出るようになっています。(BLR2-TX4,BLR-TX4Mは持っているため確認済み。)
> 外部から見るときはhttp://www.anonymizer.com/などを使うのがよいかと。
> 携帯でもできますね。
このサイトにあるhttp://sakaguch.com/WWWserver.htmlにある 5. のところでチェックしました。


その結果はどうなっていましたか?

No.11264 投稿時間:2003年07月19日(Sat) 20:36 投稿者名:eternally URL:

> このサイトにあるhttp://sakaguch.com/WWWserver.htmlにある 5. のところでチェックしました。
その結果はどうなっていましたか?


ルーターの設定はアドレス変換だけでいいのでしょうか?

No.11284 投稿時間:2003年07月20日(Sun) 07:47 投稿者名:影の支配者 URL:

> > このサイトにあるhttp://sakaguch.com/WWWserver.htmlにある 5. のところでチェックしました。
> その結果はどうなっていましたか?
もちろんエラーですけど・・・。

ルーターの設定はアドレス変換だけでいいのでしょうか?


Server Statusにエラー番号があったと思うのですが。

No.11287 投稿時間:2003年07月20日(Sun) 12:49 投稿者名:eternally URL:

> > > このサイトにあるhttp://sakaguch.com/WWWserver.htmlにある 5. のところでチェックしました。
> > その結果はどうなっていましたか?
> もちろんエラーですけど・・・。
> ルーターの設定はアドレス変換だけでいいのでしょうか?
エラーの種類を聞いていたのですが書き方が悪かったみたいですね。
Server Statusにエラー番号があったと思うのですが。


「ページを表示できません」って出たので後で調べます。

No.11295 投稿時間:2003年07月20日(Sun) 19:28 投稿者名:影の支配者 URL:

> > > > このサイトにあるhttp://sakaguch.com/WWWserver.htmlにある 5. のところでチェックしました。
> > > その結果はどうなっていましたか?
> > もちろんエラーですけど・・・。
> > ルーターの設定はアドレス変換だけでいいのでしょうか?
> エラーの種類を聞いていたのですが書き方が悪かったみたいですね。
> Server Statusにエラー番号があったと思うのですが。
今調べようと思ったらなんか「ページを表示できません」ってでたので後で調べたらまた報告したいと思います。


Server Status: Connect failed。

No.11296 投稿時間:2003年07月20日(Sun) 19:38 投稿者名:影の支配者 URL:

Status: Connection error - Connect failed
Server Status: Connect failed
Response time: 60.0156 seconds
上のように出ました。


接続失敗と言うエラーですね。

No.11297 投稿時間:2003年07月20日(Sun) 20:15 投稿者名:APACHE URL:http://kemuri-net.dip.jp/~server/

> Status: Connection error - Connect failed
> Server Status: Connect failed
> Response time: 60.0156 seconds
接続失敗と言うエラーですね。
ルーターのポートが開いてないか
プロバイダーがポートを塞いでいるか、
実はプライベートアドレスが割り当てられているかのどれか。


ルーターの【アドレス変換】はこうなっています。

No.11298 投稿時間:2003年07月20日(Sun) 20:30 投稿者名:影の支配者 URL:

> > Status: Connection error - Connect failed
> > Server Status: Connect failed
> > Response time: 60.0156 seconds
> 接続失敗と言うエラーですね。
> ルーターのポートが開いてないか
> プロバイダーがポートを塞いでいるか、
> 実はプライベートアドレスが割り当てられているかのどれか。
ルーターの設定はちゃんとなってると思いますが、自信はありません。
一応ルーターの【アドレス変換】はこうなっています。
WAN側IPアドレス プロトコル LAN側IPアドレス
ブロードステーションのWAN側IPアドレス TCP :ポート番号 80 <---> *.*.*.*
ブロードステーションのWAN側IPアドレス TCP :ポート番号 20 <---> *.*.*.*
ブロードステーションのWAN側IPアドレス TCP :ポート番号 25 <---> *.*.*.*
プロバイダはplalaです。
プライベートアドレスはたぶん割り当てられていると思います。


グローバルアドレスでないとだめです。

No.11314 投稿時間:2003年07月22日(Tue) 01:35 投稿者名:eternally URL:

> プライベートアドレスはたぶん割り当てられていると思います。
プライベートだとできませんが・・・。
グローバルでないとだめです。


ルータの設定を教えていただきたいです。

No.11315 投稿時間:2003年07月22日(Tue) 06:27 投稿者名:影の支配者 URL:

> > プライベートアドレスはたぶん割り当てられていると思います。
> プライベートだとできませんが・・・。
> グローバルでないとだめです。
あっ!そうでしたね・・・。(汗

でもそれでも外部からアクセスできないんですよね・・・。
できればルータの設定を教えていただきたいです。


サブドメインでテストを行ったとするとIPアドレスが登録されていないかもしれません。

No.11320 投稿時間:2003年07月22日(Tue) 14:16 投稿者名:eternally URL:

> でもそれでも外部からアクセスできないんですよね・・・。
> できればルータの設定を教えていただきたいです。
> WAN側IPアドレス プロトコル LAN側IPアドレス
>ブロードステーションのWAN側IPアドレス TCP :ポート番号 80 <---> *.*.*.*
*.*.*.*のところはちゃんとサーバーのアドレスになっているんですよね。

だとするとファイヤーウォールで止められているか・・・。
テストの時ってどっちでテストしましたか?IPアドレス?サブドメイン?
サブドメインでテストを行ったとするとIPアドレスがちゃんと登録されていないかもしれません。


IPアドレスでテストしました。

No.11323 投稿時間:2003年07月22日(Tue) 17:11 投稿者名:影の支配者 URL:

> > でもそれでも外部からアクセスできないんですよね・・・。
> > できればルータの設定を教えていただきたいです。
> > WAN側IPアドレス プロトコル LAN側IPアドレス
> >ブロードステーションのWAN側IPアドレス TCP :ポート番号 80 <---> *.*.*.*
> *.*.*.*のところはちゃんとサーバーのアドレスになっているんですよね。
>
> だとするとファイヤーウォールで止められているか・・・。
> テストの時ってどっちでテストしましたか?IPアドレス?サブドメイン?
> サブドメインでテストを行ったとするとIPアドレスがちゃんと登録されていないかもしれません。
IPアドレスでしました。
え~とhttp://scan.sygate.com/prequickscan.htmlで調べたらWEBのStatusがCLOSEDになっていたのでそれが原因だと思うのですが、なにぶんシロートなのでルータの設定を教えていただけたらありがたいです。


ファイヤーウォールは使っていますか?

No.11329 投稿時間:2003年07月22日(Tue) 19:42 投稿者名:eternally URL:

IPアドレスはどうやって調べましたか?
> え~とhttp://scan.sygate.com/prequickscan.htmlで調べたらWEBのStatusがCLOSEDになっていたのでそれが原因だと思うのですが、なにぶんシロートなのでルータの設定を教えていただけたらありがたいです。
ルーターの設定は間違っていません。
ファイヤーウォールは使っていますか?


基本事項の確認

No.11324 投稿時間:2003年07月22日(Tue) 18:11 投稿者名:OAK URL:

貴方の環境が不明なのですが、

1.プロバイダーは何処ですか
そこはサーバー設置可能ですか。プロバイダーが止めているかもしれません。

2.ルーターが2重に入っていませんか。
アッカやイーアクセスの場合やモデムに設定を行なった場合はたいていルーター兼用モデムです


プロバイダーのことですか?

No.11325 投稿時間:2003年07月22日(Tue) 18:44 投稿者名:影の支配者 URL:

> 貴方の環境が不明なのですが、
>
> 1.プロバイダーは何処ですか
> そこはサーバー設置可能ですか。プロバイダーが止めているかもしれません。
プロバイダーはplalaです。
> 2.ルーターが2重に入っていませんか。
> アッカやイーアクセスの場合やモデムに設定を行なった場合はたいていルーター兼用モデムです
プロバイダーのことですか?
plalaなので多分大丈夫だと思います。


モデムにルーターが内蔵されているかどうかです。

No.11328 投稿時間:2003年07月22日(Tue) 19:38 投稿者名:eternally URL:

> > 2.ルーターが2重に入っていませんか。
> > アッカやイーアクセスの場合やモデムに設定を行なった場合はたいていルーター兼用モデムです
> プロバイダーのことですか?
> plalaなので多分大丈夫だと思います。
ではなくモデムの種類です。
モデムにルーターが内蔵されているかどうかです。
わからないようだったら型番がわかれば知っている方もいるかもしれません。


モデムの型番は、NTT東日本ADSLモデム-MNII。

No.11330 投稿時間:2003年07月22日(Tue) 19:50 投稿者名:影の支配者 URL:

> > > 2.ルーターが2重に入っていませんか。
> > > アッカやイーアクセスの場合やモデムに設定を行なった場合はたいていルーター兼用モデムです
> > プロバイダーのことですか?
> > plalaなので多分大丈夫だと思います。
> ではなくモデムの種類です。
> モデムにルーターが内蔵されているかどうかです。
> わからないようだったら型番がわかれば知っている方もいるかもしれません。
ルーターはモデムに内蔵されていません。
モデムの型番 NTT東日本ADSLモデム-MNⅡ
ルーターは メルコ(BUFFALO)BLR3-TX4ユーザーズガイド
です。


LAN側IPアドレスは自宅サーバー用のパソコンのIPアドレスでいいですよね

No.11352 投稿時間:2003年07月24日(Thu) 07:16 投稿者名:影の支配者 URL:

WAN側IPアドレス プロトコル LAN側IPアドレス
ブロードステーションのWAN側IPアドレス TCP :ポート番号 80 <---> *.*.*.*
ブロードステーションのWAN側IPアドレス TCP :ポート番号 20 <---> *.*.*.*
ブロードステーションのWAN側IPアドレス TCP :ポート番号 25 <---> *.*.*.*
のLAN側IPアドレスは自宅サーバー用のパソコンのIPアドレスでいいですよね(192.*.*.*)


あとはファイヤーウォールを使っていてふさがれているとしか考えられません。

No.11355 投稿時間:2003年07月24日(Thu) 13:41 投稿者名:eternally URL:

> WAN側IPアドレス プロトコル LAN側IPアドレス
> ブロードステーションのWAN側IPアドレス TCP :ポート番号 80 <---> *.*.*.*
> ブロードステーションのWAN側IPアドレス TCP :ポート番号 20 <---> *.*.*.*
> ブロードステーションのWAN側IPアドレス TCP :ポート番号 25 <---> *.*.*.*
> のLAN側IPアドレスは自宅サーバー用のパソコンのIPアドレスでいいですよね(192.*.*.*)
そうです、あっています。
あとはファイヤーウォールを使っていてふさがれているとしか考えられません。
ファイヤーウォールは使っていますか?使っているならばソフト名は?


何か調べる方法ありませんかね?

No.11359 投稿時間:2003年07月24日(Thu) 16:29 投稿者名:影の支配者 URL:

> > WAN側IPアドレス プロトコル LAN側IPアドレス
> > ブロードステーションのWAN側IPアドレス TCP :ポート番号 80 <---> *.*.*.*
> > ブロードステーションのWAN側IPアドレス TCP :ポート番号 20 <---> *.*.*.*
> > ブロードステーションのWAN側IPアドレス TCP :ポート番号 25 <---> *.*.*.*
> > のLAN側IPアドレスは自宅サーバー用のパソコンのIPアドレスでいいですよね(192.*.*.*)
> そうです、あっています。
> あとはファイヤーウォールを使っていてふさがれているとしか考えられません。
> ファイヤーウォールは使っていますか?使っているならばソフト名は?
う~んわからないので何か調べる方法ありませんかね?
ないなら親に聞きます


だいたいタスクトレイにアイコンが入っていると思います。

No.11361 投稿時間:2003年07月24日(Thu) 19:44 投稿者名:eternally URL:

> う~んわからないので何か調べる方法ありませんかね?
> ないなら親に聞きます
だいたいタスクトレイにアイコンが入っていると思います。
ソフトによってはないのもありますが・・・。
Norton Personal Firewallやウイルスバスター200X リアルタイムモニターなどなど・・・。


やっぱりルーターの設定がダメなのでしょうか?

No.11366 投稿時間:2003年07月25日(Fri) 07:50 投稿者名:影の支配者 URL:

> > う~んわからないので何か調べる方法ありませんかね?
> > ないなら親に聞きます
> だいたいタスクトレイにアイコンが入っていると思います。
> ソフトによってはないのもありますが・・・。
> Norton Personal Firewallやウイルスバスター200X リアルタイムモニターなどなど・・・。
一応親にも聞いたし、検索かけましたが、見つかりませんでした。

やっぱりルーターの設定がダメなのでしょうか?
できればルーターの設定を一から教えて頂きたいです。


WindowsXPとかならファイヤーウォールが標準で付いているのでそれが動いてるかもしれません。

No.11374 投稿時間:2003年07月25日(Fri) 20:36 投稿者名:eternally URL:

> やっぱりルーターの設定がダメなのでしょうか?
> できればルーターの設定を位置から教えて頂きたいです。
だからルーターの設定はポートだけです。
それ以外にはありません。
WindowsXPとかならファイヤーウォールが標準で付いているのでそれが動いてるかもしれません。
方法は自分で調べてください。


windows2000なので問題ないです。

No.11375 投稿時間:2003年07月25日(Fri) 20:57 投稿者名:影の支配者 URL:

> > やっぱりルーターの設定がダメなのでしょうか?
> > できればルーターの設定を位置から教えて頂きたいです。
> だからルーターの設定はポートだけです。
> それ以外にはありません。
> WindowsXPとかならファイヤーウォールが標準で付いているのでそれが動いてるかもしれません。
> 方法は自分で調べてください。
といいましてもポートはちゃんとなってるのにな~
windows2000なので問題ないです。
とりあえずもう少し探してみます。


無事外部からのアクセスに成功しました。

No.11389 投稿時間:2003年07月27日(Sun) 19:13 投稿者名:影の支配者 URL:

皆さんのおかげで無事外部からのアクセスに成功しました。
僕の質問に答えていただいて本当にありがとうございました。
原因はルーターでした。
あとはCGIだけです。


|目次|掲示板|過去ログ目次|▲頁先頭|