投稿日:2003年07月03日 作成鷹の巣

No.10937 AN HTTPDで、PHPでSSIを使用する設定方法は?



AN HTTPDで、PHPでSSIを使用する設定方法は?

No.10937 投稿時間:2003年07月03日(Thu) 18:31 投稿者名:マック URL:

AN HTTPのオプション設定のとこで、「SSIを許可する」のとこで、チェックボックスで、選択できるようになってます!
聞きたいのは、PHPにSSIの許可できるか、また、設定できるんでしょうか?
よろしくお願いします!


Apacheでの設定例。

No.10942 投稿時間:2003年07月03日(Thu) 21:57 投稿者名:カイ URL:http://yaguma.com

> AN HTTPのオプション設定のとこで、「SSIを許可する」のとこで、チェックボックスで、選択できるようになってます!
> 聞きたいのは、PHPにSSIの許可できるか、また、設定できるんでしょうか?
当方は,vine 2.6+apache1.3.27です.環境は違いますが少し実験してみました.
まずは,うちのindex.htmlの最後に
<?php
phpinfo();
?>
を付け加えて,index.phpとしてみました.
すると,SSI以外はphpinfoを含めて表示されます.
次に,.htaccessに
AddHandler server-parsed .php
を付け加えると,SSIは表示されますが,
phpinfoは表示されませんでした.
う~ん,同居は無理なのかな?
もう少し達人の登場を待ってみましょう.


AN HTTPで、PHPをSSI許可できないかな~っと思って質問してます!

No.10979 投稿時間:2003年07月05日(Sat) 12:24 投稿者名:マック URL:

今、xoopsに挑戦してるとこなんですが、phpで、SSIがどうしても動かないので、
AN HTTPで、PHPをSSI許可できないかな~っと思って質問してます!
それか、SSIなしで、クリック数カウントするスクリプトは、存在するんでしょうか?
よろしくお願いします!


xoopsでサイトを立ててカウンタを動かしています。

No.10981 投稿時間:2003年07月05日(Sat) 15:19 投稿者名:stranger URL:

> 今、xoopsに挑戦してるとこなんですが、phpで、SSIがどうしても動かないので、
> AN HTTPで、PHPをSSI許可できないかな~っと思って質問してます!
> それか、SSIなしで、クリック数カウントするスクリプトは、存在するんでしょうか?
> よろしくお願いします!

xoopsの方で答えます
xoopsでサイトを立ててカウンタを動かしています

http://www.adslnet.org/

カウンタのxoops用モデュールを公開しています
ここのxoopsgallery 日本語化モデュール使わせてもらっています


ブロックに埋め込めるのでしょうか?

No.10988 投稿時間:2003年07月06日(Sun) 10:24 投稿者名:マック URL:

ありがとうございます!
カウンタ数っていうのが、僕の説明が悪かったと思います!
xoopsでも、マイリンクのモデュールの中で、クリック数(何回クリックしたか)っていう
機能がありますよね!
それって、ブロックに埋め込めるのでしょうか?

それと、xoopsgalleryDLさせてもらいましたが、画像が表示しないんです!
これは、どういうことでしょうか?NetPBMのパスも間違いなくOKでてるんですけどね!
ん~何処がダメなんでしょうか?良かったら、教えてください!


うちのフォーラムに詳細を書いて頂ければ、解決できるかもしれません。

No.11024 投稿時間:2003年07月08日(Tue) 10:49 投稿者名:ハル URL:

ハル@ADSLNetです。アクセスログから来ました (笑)

> それって、ブロックに埋め込めるのでしょうか?

うちで配布しているカウンタはブロックに設置して、そのブロックが表示される場合
カウントします。XOOPSAdminのブロック管理で全てのページに設定し、
グループ管理でゲストに対しても表示する設定にすれば、全てのアクセスカウントになります。
PHPのセッションを利用しているので、モジュール間移動は勿論、ブラウザを閉じない限り
同一者のカウントはカウントアップされません。

> それと、xoopsgalleryDLさせてもらいましたが、画像が表示しないんです!
> これは、どういうことでしょうか?NetPBMのパスも間違いなくOKでてるんですけどね!
> ん~何処がダメなんでしょうか?良かったら、教えてください!

アルバムの作成を行い、フォトの追加を行っても表示されないという事でしょうか?
ちょっと現状ではわかりかねます。(^^;)
出来ましたら、うちのフォーラムに詳細を書いて頂ければ、解決できるかもしれません。


|目次|掲示板|過去ログ目次|▲頁先頭|