投稿日:2003年02月12日 作成鷹の巣

No.8397 BBルーター「BAR SW-4P」のローカル・オフィスでの使い方と質問



BBルーター「BAR SW-4P」のローカル・オフィスでの使い方と質問

No.8397 投稿時間:2003年02月12日(Wed) 12:43 投稿者名:プー太郎 URL:

初めて質問します。宜しくご回答の程お願い致します。

お断り:
ジオボードでも同じ質問をしましたことをお詫び申し上げます。
急いでいますのでお許し下さい。

製品名:BAR SW-4P
使用状況:ローカル・オフィス

- Internet - Yahoo BB ADSL -
-(dhcp) P/C Router (192.168.0.1)
P/C1:RedHat 8 (192.168.0.2)
P/C2:Win2k Pro.(192.168.0.10)
WAN(192.168.0.3) BAR SW-4P LAN(192.168.1.1) -
P/C3:Win2k Pro.(192.168.1.2)

P/C Router: 1FD Mosquito 3
P/C1: BIND9、SMTP/POP3/IMAPI、Apacheサービス稼動中

BAR SW-4P:スタティック・ルーティング: マニュアル通り
ネットワーク・アドレス 0.0.0.0.
サブネットマスク 0.0.0.0
ゲートウェイ 192.168.0.1(P/C Router)
インターフェイス WAN

Q1.LAN側からはPingが通りますが、他方WAN側からが通りません。

Q2.WAN側ではサイトを閲覧することができますが、LAN側ではでき
ません。

どのように対処したらよいのでしょうか?宜しくアドバイス願いますでしょうか?

プー太郎


ルーティングを考えてゲートウェイを設定する必要があるのでしょう。

No.8399 投稿時間:2003年02月12日(Wed) 13:03 投稿者名:OAK URL:

> 初めて質問します。宜しくご回答の程お願い致します。
>
> お断り:
> ジオボードでも同じ質問をしましたことをお詫び申し上げます。
> 急いでいますのでお許し下さい。
>
> 製品名:BAR SW-4P
> 使用状況:ローカル・オフィス
>
> - Internet - Yahoo BB ADSL -
> -(dhcp) P/C Router (192.168.0.1)
> P/C1:RedHat 8 (192.168.0.2)
> P/C2:Win2k Pro.(192.168.0.10)
> WAN(192.168.0.3) BAR SW-4P LAN(192.168.1.1) -
> P/C3:Win2k Pro.(192.168.1.2)
>
> P/C Router: 1FD Mosquito 3
> P/C1: BIND9、SMTP/POP3/IMAPI、Apacheサービス稼動中
>
> BAR SW-4P:スタティック・ルーティング: マニュアル通り
> ネットワーク・アドレス 0.0.0.0.
> サブネットマスク 0.0.0.0
> ゲートウェイ 192.168.0.1(P/C Router)
> インターフェイス WAN
>
> Q1.LAN側からはPingが通りますが、他方WAN側からが通りません。

WANの各マシンにゲートウェイ 192.168.0.3 を追加する必要がありそうです

> Q2.WAN側ではサイトを閲覧することができますが、LAN側ではでき
> ません。
>
> どのように対処したらよいのでしょうか?宜しくアドバイス願いますでしょうか?

ルーターのゲートウェイに192.168.0.1(P/C Router)をいれないとだめでは?

ちょっと細かく考えていないのではっきり言えませんが、各装置から
どう言うふうにルーティングするかを考えてゲートウェイを設定する必要があるのでしょう


途中経過報告。

No.8431 投稿時間:2003年02月14日(Fri) 15:37 投稿者名:プー太郎 URL:

OAKさん、ありがとうございます。

いろいろと試していますが、一向に先へ進みません。
その一つとして、バージョンを最新版にしたのですが
今度は、LAN側からもPingが通らなくなりました。
そこでまた、元に戻しました。

> > Q1.LAN側からはPingが通りますが、他方WAN側からが通りません。
>
> WANの各マシンにゲートウェイ 192.168.0.3 を追加する必要がありそうです
*試した見たのですが、変化ありません。

> > Q2.WAN側ではサイトを閲覧することができますが、LAN側ではでき
> > ません。
> >
> > どのように対処したらよいのでしょうか?宜しくアドバイス願いますでしょうか?
>
> ルーターのゲートウェイに192.168.0.1(P/C Router)をいれないとだめでは?
*これも駄目でした。

> ちょっと細かく考えていないのではっきり言えませんが、各装置から
> どう言うふうにルーティングするかを考えてゲートウェイを設定する必要があるのでしょう
*今いえることですが、ルーティングの基礎がまったく無いので、書籍を見ながら
悪戦苦闘しているのが現状です。ルーティングとは何かがわかっていないのに・・・。
もう少し悩んでみます。


問題解決の一方法ですが。

No.8434 投稿時間:2003年02月14日(Fri) 18:23 投稿者名:おやじ URL:http://www.aconus.com/~oyaji/

こんばんは。

何故、ルータ2段構成かがあるので、答えになっていないかもしれませんが。
この問題は、今の構成では、SW-4PのWAN側の機器(P/C1、P/C2、P/C Router)がSW-4PのLAN側のネットワークの存在を知ることができないため発生している問題です。
つまり、LAN側からのパケットはWAN側機器に到達していますが、各機器のルーティングテーブルに192.168.1.0/24の情報がないため、デフォルトゲートウェイであるP/C Routerにパケットを投げてしまうため、戻ってこなくなっているのです。
これを解決するには、ripを使って、192.168.1.0/24のネットワーク(SW-4PのLAN側)が192.168.0.3(SW-4PのWAN側)の向こう側にいることを知らせるか、全ての機器にスタティックルートを切って明示する必要があります。
そのためには、あちこちいろいろな機種(OS)で設定が必要なのと、それぞれのサポートレベルの整合をとるのが面倒ですので、一番簡単な方法を以下に示します。
それは、SW-4PをNATルータとして動かすことです。具体的には、SW-4Pは、WAN側が192.168.0.3という固定IPのサービスを受けているのと同じ設定をするだけです。これにより、SW-4P配下の全ての端末のアドレスはマスカレードされるので、WAN側の機器は、192.168.0.3という端末からアクセスがあったと思いますので、192.168.0.3に帰りのパケットを投げてくれます。つまり、NATにより同一サブネット内(LAN)の通信に置き換えただけです。
もう一点、SW-4PのLAN側の端末のDNSは固定で設定してますよね。


私の場合、バージョンアップしたら直りました。

No.8436 投稿時間:2003年02月14日(Fri) 20:26 投稿者名:しゅう URL:

ファームウエアーのバージョンは R1.21 Jul.18.2002 でしょうか?
私の場合、バージョンアップしたら直りました。


空間が違っています。

No.8443 投稿時間:2003年02月15日(Sat) 03:39 投稿者名:帯鯖 URL:

帯鯖@名古屋です。

> Q1.LAN側からはPingが通りますが、他方WAN側からが通りません。
> Q2.WAN側ではサイトを閲覧することができますが、LAN側ではできません。

Q1. については…、

・ PING のルータ(SW-4P)越えができていない
このルータでは、ステルスモードの ON/OFF で、PING の応答を返すか返さないかの設定ができますよ。
この設定を変更したら、必ず「システムリブート」をしてください。

・ネットワーク構図に問題がある
おやじさんのご指摘通り、現状の構図では、PC.1, PC.2 は PC.3 を認識できません。
同じプライベートで構築していても、空間が別になっています。
これは、Q2 の原因でもあるでしょう。

私でしたら、ルーティングは GLOBAL IP <---> PRIVATE IP の1箇所のみに設置して、あとはハブを通します。
ルータが発行できるプライベート IP の最大個数まで、とりあえずハブという考えです。


|目次|掲示板|過去ログ目次|▲頁先頭|