投稿日:2003年01月14日 作成鷹の巣

No.7816 Windows XP+IIS5.1サーバー環境で、1日にたたずにアクセス出来なくなる。



Windows XP+IIS5.1サーバー環境で、1日にたたずにアクセス出来なくなる。

No.7816 投稿時間:2003年01月14日(Tue) 18:24 投稿者名:Sirius URL:

ルータ(Corega SW4P HG)を購入したので、自宅サーバを立ててみました。(このWebはとても参考にさせていただきました)
環境は
PC DELL 8200 (P4 1.7G/512MB)
OS WinXP Pro (最新のパッチ済)
ADSL FLETS 8M
Web IIS 5.1 (Web/FTP のみ起動)
ルータに接続されているPC 本機1台のみ
IP DDNS

これで、無事(といっても2hかかりましたが)サーバは立ち上がりました。
本機はサーバ用というわけではなく、当面はサーバ兼用なのですが、サーバ起動中に、いつの間にかWebに
アクセスできなくなってしまいます。(ページを表示できませんと出ます)
これは何か理由があるのでしょうか?会社でも自分のPCに同じIISを使用していますが(環境はLANですが)
WordやExcelを1日使用している状態でも、アクセスできなくなるということはありません。(メモリもCPUもスペック悪いのに)
この状態で、IISを一旦停止して(別にエラーで落ちているわけではない)再起動すると
またアクセスできるようになります。
これがIISの問題なのか?ルータとの相性なのか?よく分かりません。
もちろん、サーバ専用機にしてさわらないのがいいのですが、現状はそうも行きません。
落ちる度合いは、1hであったり5hであったりと不定期ですが1日はとても持ちません。
何か情報お持ちの方がいらっしゃったらよろしくお願いします。


私も同じような現象です

No.7821 投稿時間:2003年01月15日(Wed) 03:33 投稿者名:赤帽子 URL:

> ルータ(Corega SW4P HG)を購入したので、自宅サーバを立ててみました。(このWebはとても参考にさせていただきました)
> 環境は
> PC DELL 8200 (P4 1.7G/512MB)
> OS WinXP Pro (最新のパッチ済)
> ADSL FLETS 8M
> Web IIS 5.1 (Web/FTP のみ起動)
> ルータに接続されているPC 本機1台のみ
> IP DDNS
>
> これで、無事(といっても2hかかりましたが)サーバは立ち上がりました。
> 本機はサーバ用というわけではなく、当面はサーバ兼用なのですが、サーバ起動中に、いつの間にかWebに
> アクセスできなくなってしまいます。(ページを表示できませんと出ます)
> これは何か理由があるのでしょうか?会社でも自分のPCに同じIISを使用していますが(環境はLANですが)
> WordやExcelを1日使用している状態でも、アクセスできなくなるということはありません。(メモリもCPUもスペック悪いのに)
> この状態で、IISを一旦停止して(別にエラーで落ちているわけではない)再起動すると
> またアクセスできるようになります。
> これがIISの問題なのか?ルータとの相性なのか?よく分かりません。
> もちろん、サーバ専用機にしてさわらないのがいいのですが、現状はそうも行きません。
> 落ちる度合いは、1hであったり5hであったりと不定期ですが1日はとても持ちません。
> 何か情報お持ちの方がいらっしゃったらよろしくお願いします。

同じくcorega BAR SW4P HGを使ってます。私はDELLのPowerEdge 600SCが来るまで、Win98(P466MHz/320MB)をサーバー兼用なので
環境は全然違いますが同じような現象があります。Apacheを使ってるのでIISとは恐らく関係無いと思います。
やっぱりルーターかな?
アクセスできなくなると私の場合はネット(Web)にはアクセス出来ませんが,http://192.168.1.xxはアクセス出来て
http://127.0.0.1もアクセス出来てルーター設定画面http://192.168.1.1はいつもよりなかなか表示出来ないですが
待っていると遅いですが表示されIPを見ると61.127.xx.xxのようにIPが表示され接続中になってます。
携帯から見るとサーバーにはアクセス出来ませんでした。再接続ではアクセス出来ず再起動ではアクセス出来るようになります。
Apacheのログでは不信なログは無いようでした。落ちる頻度は5時間くらいでアップローダを設置してますがそれを閉鎖させ
全ページ移動させアクセス出来ないようにすると24時間動いてたこともありました。たまたまかもしれませんが。


Apache Error Log

No.7824 投稿時間:2003年01月15日(Wed) 11:39 投稿者名:赤帽子 URL:

[Wed Jan 15 11:36:09 2003] [notice] Parent: Created child process -203941
[Wed Jan 15 11:36:10 2003] [notice] Child -203941: Child process is running
[Wed Jan 15 11:36:10 2003] [notice] Child -203941: Acquired the start mutex.
[Wed Jan 15 11:36:10 2003] [notice] Child -203941: Starting 250 worker threads.
[Wed Jan 15 11:39:17 2003] [notice] Parent: Created child process -223133
[Wed Jan 15 11:39:17 2003] [notice] Child -223133: Child process is running
[Wed Jan 15 11:39:17 2003] [notice] Child -223133: Acquired the start mutex.
[Wed Jan 15 11:39:17 2003] [notice] Child -223133: Starting 250 worker threads.

サーバーが落ちる前にはこんなError Logが残ってました


毎回この↑Logが残ってる

No.7832 投稿時間:2003年01月15日(Wed) 22:55 投稿者名:赤帽子 URL:

> [Wed Jan 15 11:36:09 2003] [notice] Parent: Created child process -203941
> [Wed Jan 15 11:36:10 2003] [notice] Child -203941: Child process is running
> [Wed Jan 15 11:36:10 2003] [notice] Child -203941: Acquired the start mutex.
> [Wed Jan 15 11:36:10 2003] [notice] Child -203941: Starting 250 worker threads.
> [Wed Jan 15 11:39:17 2003] [notice] Parent: Created child process -223133
> [Wed Jan 15 11:39:17 2003] [notice] Child -223133: Child process is running
> [Wed Jan 15 11:39:17 2003] [notice] Child -223133: Acquired the start mutex.
> [Wed Jan 15 11:39:17 2003] [notice] Child -223133: Starting 250 worker threads.

どうやら毎回このログが残っていました。この後はWebが見れなくなる、もしくは速度が急激に落ちてます。
なぜなんでしょうか・・・


誰かお願いします

No.7872 投稿時間:2003年01月17日(Fri) 16:27 投稿者名:赤帽子 URL:

どうやら最近は1時間最悪で10分で速度落ちたりします


OSの種類とApacheのバージョンは?

No.7876 投稿時間:2003年01月17日(Fri) 18:05 投稿者名:OAK URL:

> 同じくcorega BAR SW4P HGを使ってます。私はDELLのPowerEdge 600SCが来るまで、Win98(P466MHz/320MB)をサーバー兼用なので

この表現がわかりにくい言いまわしをしていますが、
いまのサーバーマシンのOSは98ですか?
アパッチのバージョンは何ですか?

もし98でアパッチが1.3.20以前ならそんな物だとあきらめて下さい。
ただし、1.3.27とか2.を使うと改善されるかもしれませんが。


OSは、Windows98で、Apache2.0.43です。

No.7878 投稿時間:2003年01月17日(Fri) 18:25 投稿者名:赤帽子 URL:

> > 同じくcorega BAR SW4P HGを使ってます。私はDELLのPowerEdge 600SCが来るまで、Win98(P466MHz/320MB)をサーバー兼用なので
>
> この表現がわかりにくい言いまわしをしていますが、
> いまのサーバーマシンのOSは98ですか?
> アパッチのバージョンは何ですか?
>
> もし98でアパッチが1.3.20以前ならそんな物だとあきらめて下さい。
> ただし、1.3.27とか2.を使うと改善されるかもしれませんが。

98でApache2.0.43です。ポート変えてやると減ります。
Windows.NET(2003)Server RC2導入したけど発売になるまで待ってそれからサーバーやった方がいいですかね


ほんとうはLINUXを勧めたい。

No.7880 投稿時間:2003年01月17日(Fri) 18:39 投稿者名:OAK URL:

> 98でApache2.0.43です。ポート変えてやると減ります。
> Windows.NET(2003)Server RC2導入したけど発売になるまで待ってそれからサーバーやった方がいいですかね

そちらの方が安定するはずです。
現状でやるとしたら、UNIXから移植したアパッチよりはWINで最初からできているANがベター
それとサーバー動かしている間は何もしない。特にメールはだめ。なるべく余計なプログラムをはずす。
95でも6ヶ月動いたという方もおられますが、その人は日本語フェップまではずしていました。


メール等がダメというのはどういうことなのでしょうか?

No.7891 投稿時間:2003年01月18日(Sat) 08:17 投稿者名:Sirius URL:

> そちらの方が安定するはずです。
> 現状でやるとしたら、UNIXから移植したアパッチよりはWINで最初からできているANがベター
> それとサーバー動かしている間は何もしない。特にメールはだめ。なるべく余計なプログラムをはずす。
> 95でも6ヶ月動いたという方もおられますが、その人は日本語フェップまではずしていました。

★出張してて、Rep遅れてすみません。色々情報ありがとうございます。
↑のメール等がダメというのはどういうことなのでしょうか?
当面クライアントマシン兼用なので、結構厳しいのですが?マルチタスクがちゃんと動いてないってことですか?
会社のLAN環境下のXPでは問題無いのですが。。。。


よけいなところでCPUを使わないようにするためだと思います。

No.7892 投稿時間:2003年01月18日(Sat) 08:56 投稿者名:Imamura URL:

よけいなところでCPUを使わないようにするためだと思います。


リソースメーターを見てください。

No.7894 投稿時間:2003年01月18日(Sat) 10:24 投稿者名:OAK URL:

> ↑のメール等がダメというのはどういうことなのでしょうか?
> 当面クライアントマシン兼用なので、結構厳しいのですが?マルチタスクがちゃんと動いてないってことですか?
> 会社のLAN環境下のXPでは問題無いのですが。。。。

98にはリソースメーターと言うのがあります。(システムツールあたり)
ここにでる3つのパーセントを見てください。
これ内3つともおおむね30%を超える状態でないともうそれ以上のプログラム実行は危険或いは動作しないことがあり。
メーターをみながら色々なプログラムを動かしてみてください


この症状は最近になってからです。

No.7907 投稿時間:2003年01月18日(Sat) 18:32 投稿者名:赤帽子 URL:

> 98にはリソースメーターと言うのがあります。(システムツールあたり)
> ここにでる3つのパーセントを見てください。
> これ内3つともおおむね30%を超える状態でないともうそれ以上のプログラム実行は危険或いは動作しないことがあり。
> メーターをみながら色々なプログラムを動かしてみてください

常駐はZoneだけなので1日置いてても70%くらいです。(メールは携帯でいいのでOutlook等もインストールさえしてません)
80%くらいの時にでもなぜか同じErroeLogが残り、速度が5Mbpsから600kbps程までに下がったりWebに繋がらなくなります。
あとこの症状は最近になってからです


SW4PHGについて

No.7921 投稿時間:2003年01月19日(Sun) 17:15 投稿者名:にしむら URL:http://penguin.nakayosi.jp/

お使いの corega SW4PHGなんですが、私も似たような経験があります。Windows2000+ANHTTPDですけど。(^^;
サーバPCの問題でなく、SW4PHGの熱暴走の可能性が大です。本体をさわってみるとわかるのですが、かなりの熱をだしているはずです。これでスループットがおちたり、本体がフリーズしたりしてるようなんです。価格.com の「口コミ掲示板」でときどき話題になってます。あまりにも頻繁におこるようなら、新品に交換してくれるそうです。


凄い熱ですよね。

No.7924 投稿時間:2003年01月19日(Sun) 19:17 投稿者名:赤帽子 URL:

> お使いの corega SW4PHGなんですが、私も似たような経験があります。Windows2000+ANHTTPDですけど。(^^;
> サーバPCの問題でなく、SW4PHGの熱暴走の可能性が大です。本体をさわってみるとわかるのですが、かなりの熱をだしているはずです。これでスループットがおちたり、本体がフリーズしたりしてるようなんです。価格.com の「口コミ掲示板」でときどき話題になってます。あまりにも頻繁におこるようなら、新品に交換してくれるそうです。

凄い熱ですよね。ヒーターの無い部屋に置いてるのに。
新品ですか、coregaに電話したらいいのかな
前使ってたSW-4P Proもあるけど


電源を入れてから数日で・・・。

No.7925 投稿時間:2003年01月19日(Sun) 19:58 投稿者名:にしむら URL:http://penguin.nakayosi.jp/

> 凄い熱ですよね。ヒーターの無い部屋に置いてるのに。
> 新品ですか、coregaに電話したらいいのかな

私の場合は、SW4PHG の電源を入れてから数日で、次のような
コトがおきてました。

・スループットがおちる。
・ときどきLAN側のリンクが切れる。
・いつのまにかフリーズしてる。

すべて SW4PHG の電源のOFF/ONで回復してました。

あくまでウワサですが、コレガのサポートではらちがあかず、
仕方ないので、販売店と "初期不良" で交渉する場合が多い
らしいです。

私は交渉が面倒くさかったので、さっさと SuperOPT90 に買い
かえました。SW4PHG はネットオークションでめでたく嫁ぎ先が
決まりました。

ちなみに SuperOPT90 にかえてから、サーバPCは、ずーっと
正常に動いています。スループット低下もありませんし、フ
リーズもしません。p(^-^)q


> 前使ってたSW-4P Proもあるけど

スループットが少しおちるようですが、試してみてはいかがで
しょうか。ものはためし、です。(^_^


私はProですが同じような症状で悩まされました。

No.7929 投稿時間:2003年01月19日(Sun) 22:01 投稿者名:カイナン URL:http://yaguma.com

私はProですが同じような症状で悩まされました.サーバの調子が悪くなり,Webは見れなくなる,DNSは引けなくなると散々でした.何をしてもなおらず,結局,ルータのリセットでなおるのですが,しばらくすると同じ状態になってしまい,ルータをメルコのBLRに変えることで調子がよくなりました


コレガはやめます

No.7930 投稿時間:2003年01月19日(Sun) 22:22 投稿者名:赤帽子 URL:

> 私はProですが同じような症状で悩まされました.サーバの調子が悪くなり,Webは見れなくなる,DNSは引けなくなると散々でした.何をしてもなおらず,結局,ルータのリセットでなおるのですが,しばらくすると同じ状態になってしまい,ルータをメルコのBLRに変えることで調子がよくなりました

ではProも駄目ですねえ。もうコレガはやめます。メルコのルーター、安いルーターで評判いいですよね。
OPT90はまあまあの値段で評判いいですね、ただ設定が難しそう。3月に光来るからスループレットがちょっと悪いようですし。
あと質問なんですが今ノートPCだけなのですがお年玉が入ったのでサーバー用にサーバー機買おうと思うのですが
マウスとかキーボードとかモニターいりますか?ノートPCに繋げたりで出来ますか?
やっぱり自作以外ならDELLがいいですかね、後からCPU変えたりできるのかな・・・
なんか質問ばっかりですいません


OPT90の設定を公開しました。(御参考)

No.7946 投稿時間:2003年01月20日(Mon) 20:01 投稿者名:おやじ URL:http://www.aconus.com/~oyaji/

こんばんは。

> ではProも駄目ですねえ。もうコレガはやめます。メルコのルーター、安いルーターで評判いいですよね。
> OPT90はまあまあの値段で評判いいですね、ただ設定が難しそう。3月に光来るからスループレットがちょっと悪いようですし。

人柱になってくださる方がいらっしゃったので、試験してもらったOPT90の設定を本日公開しました。
フラグが使えるので、かなり細かい設定をしてあります。ご参考まで。

http://www.aconus.com/~oyaji/router/router.htm


OPT90に乗り換えようかな。

No.7986 投稿時間:2003年01月22日(Wed) 11:20 投稿者名:赤帽子 URL:

> こんばんは。
>
> > ではProも駄目ですねえ。もうコレガはやめます。メルコのルーター、安いルーターで評判いいですよね。
> > OPT90はまあまあの値段で評判いいですね、ただ設定が難しそう。3月に光来るからスループレットがちょっと悪いようですし。
>
> 人柱になってくださる方がいらっしゃったので、試験してもらったOPT90の設定を本日公開しました。
> フラグが使えるので、かなり細かい設定をしてあります。ご参考まで。
>
> http://www.aconus.com/~oyaji/router/router.htm

痛いけどOPT90に乗り換えようかな
ありがとうございます。買った時用にお気に入りに登録しときました


Proを1年くらいにわたって使ってきましたので,単なる故障かもしれません。

No.7948 投稿時間:2003年01月20日(Mon) 21:46 投稿者名:カイナン URL:http://yaguma.com

私の場合Proを1年くらいにわたって使ってきましたので,単なる故障かもしれません.話の流れからするとコレガを否定するような感じですがそんなつもりはないです.サーバが調子悪くなったのは,ルータが原因ということもあるということです.


BAR SW-4P は安定してます

No.7954 投稿時間:2003年01月20日(Mon) 23:09 投稿者名:あくちゃん URL:

> > 私はProですが同じような症状で悩まされました.サーバの調子が悪くなり,Webは見れなくなる,DNSは引けなくなると散々でした.何をしてもなおらず,結局,ルータのリセットでなおるのですが,しばらくすると同じ状態になってしまい,ルータをメルコのBLRに変えることで調子がよくなりました
>
> ではProも駄目ですねえ。もうコレガはやめます。

みなさん散々のご様子ですね。私は無印のコレガのルータ SW-4P をかれこれ1年以上使っていますが、ルーターが原因と思われる不具合は起こってないです。(^^v 機能がいっぱいあると負荷がかかってダメなのかもしれませんし、私が使っているのがタマタマ当たりだったのかもしれませんし。スループットは最大9.5Mbpsだったと思いますが、下りで2.7Mbpsしか出てない環境では何の不都合もなくサーバー運営が出来てま~す♪


Windows.NETでもネットに繋がらなくなる

No.7985 投稿時間:2003年01月22日(Wed) 11:18 投稿者名:赤帽子 URL:

[Tue Jan 21 18:01:29 2003] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Tue Jan 21 18:01:29 2003] [notice] Child 940: Exit event signaled. Child process is ending.
[Tue Jan 21 18:01:30 2003] [notice] Child 940: Released the start mutex
[Tue Jan 21 18:01:31 2003] [notice] Child 940: Waiting for 250 worker threads to exit.
[Tue Jan 21 18:01:31 2003] [notice] Child 940: All worker threads have exited.
[Tue Jan 21 18:01:31 2003] [notice] Child 940: Child process is exiting
[Tue Jan 21 18:01:31 2003] [notice] Parent: Child process exited successfully.

Windows.NET入れたのですがApacheで試験すると
やっぱりこういうError.logが10分後に残りネットに繋がらなくなりました。ルーターとPC再起動させたら直りましたが。
httpd.confの書き方のせいでApacheのセキュリティ的に駄目になってるかルーターが駄目なのかカナ


AN HTTPDでは、少し長持ちするようになりました。

No.8006 投稿時間:2003年01月23日(Thu) 23:32 投稿者名:赤帽子 URL:

AN HTTPD導入しますと少し長持ちするようになりました


AN HTTPDで、Webに繋がらなくなりました。

No.8010 投稿時間:2003年01月24日(Fri) 13:41 投稿者名:赤帽子 URL:

AN HTTPDの導入結果ですがサーバーは1日置いてても落ちませんでしたが
Webに繋がらなくなりました。でも携帯から見るとサーバー見れますがサーバーからここなどのWebを見ようとすると
無理でした


あくまで参考情報ですが・・・

No.8016 投稿時間:2003年01月24日(Fri) 18:47 投稿者名:おやじ URL:http://www.aconus.com/~oyaji/

こんばんは

> AN HTTPDの導入結果ですがサーバーは1日置いてても落ちませんでしたが
> Webに繋がらなくなりました。でも携帯から見るとサーバー見れますがサーバーからここなどのWebを見ようとすると
> 無理でした

あくまで参考情報ですが・・・

おやじが相談を受けた方で、Crega SW-4P Proを使用していて、何もしないである時間が経つと外部からWebページが見れなくなるというトラブルありました。
この時、家庭内からインターネットアクセスすれば、その状態から離脱できるという現象でした。
いろいろ切り分けた結果、10分以内に方向に関係なくルータにパケットがとおれば問題は出ないが、20分以上空いてしまうとその現象がでることが判明しました。
そこで、その方はLinuxだったので、サーバの時刻同期も兼ねてntpdを動かし、デフォルトでは同期してくると最大ポーリング間隔が1024秒になってしまうので、最大ポーリング間隔を一段下げて512秒で動作させたところ、以降問題はまったく発生しなくなったという事例があります。
おかしくなっている方向が違うので、違うかもしれませんが、Windowsなら同じようにサーバの時刻同期も兼ねて桜時計を10分間隔ぐらいで動かしてみてはどうでしょうか?NTPサーバに負荷がかかるので、短くしすぎないように。


導入してみます/ネットサーフィン中は大丈夫なので

No.8022 投稿時間:2003年01月24日(Fri) 21:07 投稿者名:赤帽子 URL:

> こんばんは
>
> > AN HTTPDの導入結果ですがサーバーは1日置いてても落ちませんでしたが
> > Webに繋がらなくなりました。でも携帯から見るとサーバー見れますがサーバーからここなどのWebを見ようとすると
> > 無理でした
>
> あくまで参考情報ですが・・・
>
> おやじが相談を受けた方で、Crega SW-4P Proを使用していて、何もしないである時間が経つと外部からWebページが見れなくなるというトラブルありました。
> この時、家庭内からインターネットアクセスすれば、その状態から離脱できるという現象でした。
> いろいろ切り分けた結果、10分以内に方向に関係なくルータにパケットがとおれば問題は出ないが、20分以上空いてしまうとその現象がでることが判明しました。
> そこで、その方はLinuxだったので、サーバの時刻同期も兼ねてntpdを動かし、デフォルトでは同期してくると最大ポーリング間隔が1024秒になってしまうので、最大ポーリング間隔を一段下げて512秒で動作させたところ、以降問題はまったく発生しなくなったという事例があります。
> おかしくなっている方向が違うので、違うかもしれませんが、Windowsなら同じようにサーバの時刻同期も兼ねて桜時計を10分間隔ぐらいで動かしてみてはどうでしょうか?NTPサーバに負荷がかかるので、短くしすぎないように。

こんばんは。
よくよく考えてみるとネットサーフィン中は朝から夜とかでも大丈夫でした。
やってみます。ありがとうございます


いけました/ポート変更

No.8036 投稿時間:2003年01月25日(Sat) 19:57 投稿者名:赤帽子 URL:

桜時計起動させてたらパフォーマンスは悪くなった?ですが大丈夫でした。
本当にありがとうございます

あとセキュリティが心配なのでポート変更して少しでも安全にしようかと思ってますが
Dyndnsだとhttp://xxx.dyndns.tvhttp://xox.dyndns.org:8080に飛ばそうとしましたが
元URLが出てポートが分かって少しダサいのですがこれは避けれないでしょうか?
hn.orgやno-ipなどでも試しましたが同様でした


|目次|掲示板|過去ログ目次|▲頁先頭|