投稿日:2003年01月10日 作成鷹の巣

No.7748 /sbin/service httpd statusとすると「サブシステムがロックしています。」という表示が出ます。



/sbin/service httpd statusとすると「サブシステムがロックしています。」という表示が出ます。

No.7748 投稿時間:2003年01月10日(Fri) 13:12 投稿者名:ぐり URL:

こんにちは。
いろいろ自分なりに調べてはいるのですが、解決できないので
わかる方教えてください。

APACHEの再起動をする際に起こるエラーで悩んでいるのですが、

「/sbin/service httpd restart」

とやって再起動をしようとすると、STOPもSTARTも「OK」と
表示されるのですが、ホームページが表示されず、

「/sbin/service httpd status」としてみると

「サブシステムがロックしています。」

という表示がでてしまい、毎回、システム自体を再起動する羽目に
なってしまいます。
また、

「/sbin/service httpd stop」

とした後に

「/sbin/service httpd start」

としてもやはり同じ現象が起こります。

以前はできていたような気がするのですが、中をいろいろ扱ってしまい
なにを戻すのかわからない状態です。
apacheのバージョンは 1.3.27 です。

よろしくお願いします。


OSはXPでは?

No.7751 投稿時間:2003年01月10日(Fri) 14:11 投稿者名:Taka_P URL:

OSはXPでは?

XPではたしかリスタートができないと・・違ったかな?


SSHで、RedHatLinux7.3にアクセスしています。

No.7752 投稿時間:2003年01月10日(Fri) 15:08 投稿者名:ぐり URL:

> OSはXPでは?
>
> XPではたしかリスタートができないと・・違ったかな?

情報が少なかったですね。申し訳ありません。
操作する側のOSはWIN2000で、SSHを使い、RedHatLinux7.3にアクセスしています。


Killしたり、ロックファイルを削除するなりすればよいかと思います。

No.7753 投稿時間:2003年01月10日(Fri) 16:16 投稿者名:水芹 URL:http://www.dream-seed.com

こんにちは。

前は動いていて、いろいろいじったらだめになったということは、
いじった部分を一つ一つ確認するしか方法がないような気がしますが・・・。

まず、エラーログにそれっぽいことが書かれていないか確認してみてください。

それと、システム自体を再起動しなくてもKillしたり、ロックファイルを削除するなりすればよいかと思います。

ちょっと検索したら、似たような症状の記事がありました。
http://www1.plala.or.jp/yuuto/linux/p07.html
これとまったく同じ現象かどうかはわかりませんが、参考までに・・・。


できました。

No.7754 投稿時間:2003年01月10日(Fri) 18:28 投稿者名:ぐり URL:

教えていただいたホームページを参考に、
ロックファイルを削除して再起動という簡単な方法で解決することができました。^^;
リモートからでも問題なくRESTARTできました。
ありがとうございました。


|目次|掲示板|過去ログ目次|▲頁先頭|