投稿日:2002年12月26日 作成鷹の巣

No.7332 再度:: ルーターモデム(ATerm DR-202C)の設定方法を教えてください。



再度:: ルーターモデム(ATerm DR-202C)の設定方法を教えてください。

No.7332 投稿時間:2002年12月26日(Thu) 11:48 投稿者名:yoshi URL:

いつもお世話になります.
おやじさん、鷹の巣さん、前回の回答どうもありがとうございました
引越しでいまだにどたばたして、前回から一週間ほどたちましたが、
いまだにかたづいておらず。いざ、掲示板のチェックをしてみると
前回の葉過去ログにされてしまいましたので再度
続きをかかせていただきます。

>おやじさんへ
もともとの TE4121C(MegaBit Gear)の設定では
No. : 1
優先度 : 1
インターフェース : LANから受信
送信元IPアドレス/マスク長 : 172.25.0.0/24
送信先IPアドレス/マスク長 : 0.0.0.0/0
プロトコル : ICMP
送信元ポート番号 : *
送信先ポート番号 : *
アクション : 通過

No. : 2
優先度 : 2
インターフェース : 接続先1から受信
送信元IPアドレス/マスク長 : 0.0.0.0/0
送信先IPアドレス/マスク長 : (PPP取得)
プロトコル : ICMP
送信元ポート番号 : *
送信先ポート番号 : *
アクション : 通過

になっていました。
内容はLAN内のクライアントがPINGを使えるようにしているものです。
お聞きしたいのはこの設定で(PPP取得)の部分に関してのアドレス表記です。
TE4121Cでは自動的に現在のプロバイダから与えられているグローバルアドレスが
設定されるということでしょうか?
TE4121Cにおいてはこのような設定がないので、固定アドレスでない限りは
『*』で設定するほかなく、そうなるとすべてのアドレスを通過させてしまうということですよね。

>鷹の巣さんへ
過去ログ掲載ありがとうございます.
過去ログを確認しました.行き着く先はIPパケットフィルタの設定は必要がない?
ということで解決しているようです。ポートマッピングだけの設定とあります。
IPパケットフィルタの設定をしなければポートマッピング以外のポートに関しては
非通過ということなんでしょうか?
現状では、WWWサーバーとFTPサーバーは外部からの参照ができます。
メールサーバーに関しては受信はできるのですが送信ができません。

もちろん、アウトルックExpのサーバー情報のSMTPをローカルからプロバイダーの
メールサーバーのアドレスに変更すればメールの送信はできます。
アウトルックExpのサーバー設定で受信メールサーバーの種類が『POP3』
ですが、ポートマッピングでの表示は『POP3』の設定ができず『POP』になります。
ただ、アウトルックExpの詳細設定でのPOP3のアドレス『110』で
ポートマッピングの設定をしても最終的に『POP』と表示されています。
送信できないのはIPフィルタの設定をしていないからでしょうか?

以上、おやじさん、鷹の巣さん
すみませんが回答よろしくお願いします.

また、おやじさん、鷹の巣さん以外でもわかる人がいれば教えてください。
よろしくおねがいします。


私の「ポートマッピング設定」。

No.7347 投稿時間:2002年12月26日(Thu) 16:13 投稿者名:伊藤淳 URL:

過去ログを賑わした。伊藤淳です。

> 過去ログを確認しました.行き着く先はIPパケットフィルタの設定は必要がない?
> ということで解決しているようです。ポートマッピングだけの設定とあります。
繋がらない、送れない、だけの問題なら、パケットフィルタ設定は取り合えず
横に置いといてということではなかったでしょうか。
私の「ポートマッピング設定」を下記に示します。
【NATエントリ】
エントリ番号 変換対象ポート 変換対象プロトコル 宛先アドレス 宛先ポート
01 www TCP 192.168.0.200 www
02 smtp TCP 192.168.0.200 smtp
03 pop TCP 192.168.0.200 pop
192.168.0.200->サーバのIPアドレス
* www->80 smtp->25 pop->110

> IPパケットフィルタの設定をしなければポートマッピング以外のポートに関しては
> 非通過ということなんでしょうか?
正確に答えらないのでパス。
> 現状では、WWWサーバーとFTPサーバーは外部からの参照ができます。
> メールサーバーに関しては受信はできるのですが送信ができません。
設定が上記のようになっていれば、ルーターの問題ではなく、
メールサーバーの問題ではないでしょうか?。


ルータは問題ないと思いますが。

No.7355 投稿時間:2002年12月26日(Thu) 23:37 投稿者名:おやじ URL:http://www.aconus.com/~oyaji/

> いつもお世話になります.
> おやじさん、鷹の巣さん、前回の回答どうもありがとうございました
> 引越しでいまだにどたばたして、前回から一週間ほどたちましたが、
> いまだにかたづいておらず。いざ、掲示板のチェックをしてみると
> 前回の葉過去ログにされてしまいましたので再度
> 続きをかかせていただきます。
>
> >おやじさんへ
> もともとの TE4121C(MegaBit Gear)の設定では
> No. : 1
> 優先度 : 1
> インターフェース : LANから受信
> 送信元IPアドレス/マスク長 : 172.25.0.0/24
> 送信先IPアドレス/マスク長 : 0.0.0.0/0
> プロトコル : ICMP
> 送信元ポート番号 : *
> 送信先ポート番号 : *
> アクション : 通過
>
> No. : 2
> 優先度 : 2
> インターフェース : 接続先1から受信
> 送信元IPアドレス/マスク長 : 0.0.0.0/0
> 送信先IPアドレス/マスク長 : (PPP取得)
> プロトコル : ICMP
> 送信元ポート番号 : *
> 送信先ポート番号 : *
> アクション : 通過
>
> になっていました。
> 内容はLAN内のクライアントがPINGを使えるようにしているものです。
> お聞きしたいのはこの設定で(PPP取得)の部分に関してのアドレス表記です。
> TE4121Cでは自動的に現在のプロバイダから与えられているグローバルアドレスが
> 設定されるということでしょうか?
> TE4121Cにおいてはこのような設定がないので、固定アドレスでない限りは
> 『*』で設定するほかなく、そうなるとすべてのアドレスを通過させてしまうということですよね。

上記設定は、全て通過になります。TE4121Cの表現が悪いのですが、接続先1から受信とはWANの入り口で
フィルタするという意味で、WAN側からグローバルアドレスにきたパケットをどう処理するかを定義するものです。


> >鷹の巣さんへ
> 過去ログ掲載ありがとうございます.
> 過去ログを確認しました.行き着く先はIPパケットフィルタの設定は必要がない?
> ということで解決しているようです。ポートマッピングだけの設定とあります。
> IPパケットフィルタの設定をしなければポートマッピング以外のポートに関しては
> 非通過ということなんでしょうか?

DR-202のフィルタは、暗黙のAllowになっていますので、フィルタにマッチしなければ
通過します。また、フラグを扱えないので、限定的なDenyフィルタ(遮断フィルタ)しか
設定できません。従って、ICMPに関しては、デフォルトで通過するはずです。

> 現状では、WWWサーバーとFTPサーバーは外部からの参照ができます。
> メールサーバーに関しては受信はできるのですが送信ができません。
>
> もちろん、アウトルックExpのサーバー情報のSMTPをローカルからプロバイダーの
> メールサーバーのアドレスに変更すればメールの送信はできます。
> アウトルックExpのサーバー設定で受信メールサーバーの種類が『POP3』
> ですが、ポートマッピングでの表示は『POP3』の設定ができず『POP』になります。
> ただ、アウトルックExpの詳細設定でのPOP3のアドレス『110』で
> ポートマッピングの設定をしても最終的に『POP』と表示されています。
> 送信できないのはIPフィルタの設定をしていないからでしょうか?

POPの件は伊藤さんが回答してくれているので置いておきます。
メールの送信の件は、

1. 主語がはっきりしません。
2. インターネット通信は、2つの端末間の通信です。どこから、どこへ、どういうルート
の通信がOK/NGかがはっきりしないと、何もわかりません。絵を書いて、ひとつひとつ
通信ルートを確認していくことを薦めます。
3. 通信がうまくいかないのには理由があり、おかしいことはサーバがログに吐いていて
くれるはず。まずは、その内容から原因を突き止めるのが順当なアプローチです。

で、プロバイダのサーバを設定すれば送信できるということは、家庭内から25番で外へ
出られるということですから、SMTPサーバもおなじ25番で外部へ送信するので、ルータの
フィルタは問題ないでしょう。推定されるのが、サーバ機にDNSの設定がしておらず、
サーバ機で外部のHPが見えない状態になっている。 もう一つは、リレーの設定ミスぐらい
ですかね。いずれにしてもログを見てみてください。そこからです。


|目次|掲示板|過去ログ目次|▲頁先頭|