投稿日:2002年12月06日 作成鷹の巣

No.6735 Windows2000のAn HTTPDがLAN内からアクセスできない。



Windows2000のAn HTTPDがLAN内からアクセスできない。

No.6735 投稿時間:2002年12月06日(Fri) 17:50 投稿者名:斎藤 URL:

初めまして斎藤と申します。よろしくお願いします。
Windows2000SP3をクリーンインストールして(NTFSファーマット)
WindowsUpdateで今日現在の全てのパッチは当ててあります。
Argosoft MailserverとAn HTTPDをインストールしました。
IPアドレス192.168.1.2
初期設定をすませて、このマシンでメールの送受信テスト
MailserverのWeb画面テスト、An HTTPDのテストをすませて
大丈夫だったのですが、LAN内の他のマシンからテストを
行うと、メールの送受信はうまく行くのですが、
MailserverのWeb画面及びAn HTTPDの表示がされません。
両方ともログにはアクセスされたログが残りますが表示されないのです。
テストを行ったLAN内のマシンは3台で全てWindows2000IE6、プロキシ設定はされて
いません。
ローカルエリア接続のプロパティもチェックしましたが
TCP/IPフィルタリング設定はされていませんでした。


ブラウザのキャッシュを一旦削除して、外部からアクセスして見て下さい。

No.6743 投稿時間:2002年12月07日(Sat) 08:03 投稿者名:鷹の巣 URL:http://sakaguch.com/

> 初期設定をすませて、このマシンでメールの送受信テスト
> MailserverのWeb画面テスト、An HTTPDのテストをすませて
> 大丈夫だったのですが、LAN内の他のマシンからテストを
> 行うと、メールの送受信はうまく行くのですが、
> MailserverのWeb画面及びAn HTTPDの表示がされません。
> 両方ともログにはアクセスされたログが残りますが表示されないのです。

メールサーバーには、問題がなくて、An HTTPDだけの問題でしょうか。

> テストを行ったLAN内のマシンは3台で全てWindows2000IE6、プロキシ設定はされて
> いません。

ブラウザのキャッシュを一旦削除して、外部からアクセスして見て下さい。
http://sakaguch.com/WWWserver.html#WWWtest


ブラウザのキャッシュは削除してみましたがダメでした。

No.6756 投稿時間:2002年12月07日(Sat) 23:11 投稿者名:斎藤 URL:

> メールサーバーには、問題がなくて、An HTTPDだけの問題でしょうか。

メールサーバのpop3&smtpには問題なく、メールサーバのhttpd機能(ポートは80から替えています)
An HTTPD両方が、サーバ設置のマシンからは見れて、LAN内のマシンからは
見れません。当然WAN側からも見ることが出来ません。
但し、ログには200で正常に返しているようです。

> ブラウザのキャッシュを一旦削除して、外部からアクセスして見て下さい。
> http://sakaguch.com/WWWserver.html#WWWtest

ブラウザのキャッシュは削除してみましたがダメでした。


CGIや単なるテキストなどは正しく表示されました。

No.6767 投稿時間:2002年12月09日(Mon) 09:33 投稿者名:斎藤 URL:

追記です。
さらに色々テストしてみたところ、
CGIや単なるテキストなどは正しく表示されました。
拡張子html,htmのみ帰ってきません。


IPアドレスの逆引きの名前解決が出来ていない可能性もあるのでは、と考えています。

No.6777 投稿時間:2002年12月09日(Mon) 20:34 投稿者名:鷹の巣 URL:http://sakaguch.com/

> CGIや単なるテキストなどは正しく表示されました。
> 拡張子html,htmのみ帰ってきません。

ちょっと、状況がわかりませんが、
1.AN HTTPDの入っているサーバー機自身から、http://127.0.0.1/
2.LAN内のクライアント機から、(インターネットを介さずに)http://サーバー機のプライベートアドレス/
3.WAN側(インターネット側)から、http://www.example.com/
で、アクセスするとどの様な結果になりますか?

4.AN HTTPDの一般タブで、「リモートホストを取得しない」になっていますでしょうか。
5.「リモートホストを取得しない」以外に設定されているのでしたら、
サーバー機のhostファイルにLAN内のクライアント機のIPアドレスとそのホスト名を設定したら、
どうなるのかも教えて下さい。

IPアドレスの逆引きの名前解決が出来ていない可能性もあるのでは、と考えています。


OnboardのNICが怪しいと疑っています。

No.6802 投稿時間:2002年12月10日(Tue) 09:17 投稿者名:斎藤 URL:

> 1.AN HTTPDの入っているサーバー機自身から、http://127.0.0.1/

全てOKです。

> 2.LAN内のクライアント機から、(インターネットを介さずに)http://サーバー機のプライベートアドレス/

html,htm共に表示されません

> 3.WAN側(インターネット側)から、http://www.example.com/
> で、アクセスするとどの様な結果になりますか?

2.と同様です。

> 4.AN HTTPDの一般タブで、「リモートホストを取得しない」になっていますでしょうか。

常時になっていました。

> 5.「リモートホストを取得しない」以外に設定されているのでしたら、
> サーバー機のhostファイルにLAN内のクライアント機のIPアドレスとそのホスト名を設定したら、
> どうなるのかも教えて下さい。

変わりません

同じ内容の質問を中田さんのGuestBookにもしていますがご容赦下さい。
中田さんの過去ログを探ったところ、私とほぼ同じ状況の方が
いらっしゃった上、M/Bも一緒だったのでOnboardのNICが怪しいと
疑っています。


サーバー機自身のブラウザから、インターネットのWebページは、見れますか。

No.6811 投稿時間:2002年12月10日(Tue) 15:48 投稿者名:鷹の巣 URL:http://sakaguch.com/

> > 4.AN HTTPDの一般タブで、「リモートホストを取得しない」になっていますでしょうか。
>
> 常時になっていました。

試しに、「リモートホストを取得しない」にして一度動作確認して下さい。

> いらっしゃった上、M/Bも一緒だったのでOnboardのNICが怪しいと
> 疑っています。

サーバー機自身のOnboardのNICを通して、インターネットのWebページは、見れるのでしょうか。
(サーバー機自身のブラウザから、インターネットのWebページは、見れますか。)


解決しました

No.6824 投稿時間:2002年12月10日(Tue) 23:03 投稿者名:斎藤 URL:

> 試しに、「リモートホストを取得しない」にして一度動作確認して下さい。

試しましたが同様でした。

> サーバー機自身のOnboardのNICを通して、インターネットのWebページは、見れるのでしょうか。
> (サーバー機自身のブラウザから、インターネットのWebページは、見れますか。)

見れます。これは全く問題なく。

結局、NICをPCIで差して、そちら側を経由することによって
問題を回避しました。(解決とは言えないかもしれませんが)
色々調べたり聞いたところによると、私の使っているM/BのオンボードLANは
OSを選ばない不具合を持っているようです。

鷹の巣さんアドバイスありがとうございました。


|目次|掲示板|過去ログ目次|▲頁先頭|