投稿日:2002年11月03日 作成鷹の巣

No.6181 An httpdとライブカメラの共存について



An httpdとライブカメラの共存について

No.6181 投稿時間:2002年11月03日(Sun) 23:45 投稿者名:kazu URL:

サーバー構築の時は管理人さんをはじめ皆さんにご迷惑かけました。有り難うございます。
簡単なライブカメラ(動画)を設置しようと思いTeveoのフリーソフトをダウンロードしてポート8080で設定。
An httpdをポート80で設定しましたがライブカメラが見れません。(Web側)
実際ローカルではライブカメラの動画もAnhttpdのほうも見れるのにどういうことでしょうか?

また、同じようなことをやってらっしゃる方がいましたら、アドバイスお願いします。


もう少し詳しくご説明願います。

No.6208 投稿時間:2002年11月04日(Mon) 16:34 投稿者名:鷹の巣 URL:http://sakaguch.com/

> 簡単なライブカメラ(動画)を設置しようと思いTeveoのフリーソフトをダウンロードしてポート8080で設定。
> An httpdをポート80で設定しましたがライブカメラが見れません。(Web側)
> 実際ローカルではライブカメラの動画もAnhttpdのほうも見れるのにどういうことでしょうか?


ルータをご使用でしょうか?
An httpdは、インターネット側から見れるのでしょうか?
Webサーバー同様8080番もインターネットに開放されていますでしょうか?
Windows XPでしたら、TCP/IPの設定にもファイヤウォールがありますけど、
Webサーバーと同様の設定をどの程度行われたのかもう少し詳しくご説明願います。


ポート80で設定したカメラサーバーは、インターネット側から見れるようです。

No.6218 投稿時間:2002年11月05日(Tue) 00:37 投稿者名:kazu URL:

> > 簡単なライブカメラ(動画)を設置しようと思いTeveoのフリーソフトをダウンロードしてポート8080で設定。
> > An httpdをポート80で設定しましたがライブカメラが見れません。(Web側)
> > 実際ローカルではライブカメラの動画もAnhttpdのほうも見れるのにどういうことでしょうか?
>
>
> ルータをご使用でしょうか?
富士通のモデム使用中です。アッカ12Mです。
> An httpdは、インターネット側から見れるのでしょうか?
見れます。以前お世話になりました。

> Webサーバー同様8080番もインターネットに開放されていますでしょうか?
しています。
> Windows XPでしたら、TCP/IPの設定にもファイヤウォールがありますけど、
win2000です。
> Webサーバーと同様の設定をどの程度行われたのかもう少し詳しくご説明願います。
> >
> > また、同じようなことをやってらっしゃる方がいましたら、アドバイスお願いします。

WEBサーバーのソフトを停止させ、ポート80で設定したカメラサーバーは見れるようですが、
ポートを8080にするとどのようにしてもみれません。


ポート番号を逆にしたら、どうなるかテストできますか?

No.6222 投稿時間:2002年11月05日(Tue) 06:31 投稿者名:OAK URL:

> WEBサーバーのソフトを停止させ、ポート80で設定したカメラサーバーは見れるようですが、
> ポートを8080にするとどのようにしてもみれません。

どうもルーターの8080の方の設定という気がします。
WEBとカメラのポートを逆にしたらどうなりますかテストできますか?


両方試しましたがだめでした。

No.6235 投稿時間:2002年11月05日(Tue) 23:03 投稿者名:kazu URL:

> どうもルーターの8080の方の設定という気がします。
> WEBとカメラのポートを逆にしたらどうなりますかテストできますか?

8080でWEBを起動しましたが、グローバルIP:8080とドメイン:8080
両方試しましたがだめでした。ルーター、モデムポート8080は開けてあるのに....?


両方同時には、公開出来ないということですね。

No.6238 投稿時間:2002年11月05日(Tue) 23:48 投稿者名:鷹の巣 URL:http://sakaguch.com/

> 8080でWEBを起動しましたが、グローバルIP:8080とドメイン:8080
> 両方試しましたがだめでした。ルーター、モデムポート8080は開けてあるのに....?

各々単独に8080番でWebサーバーと80番でカメラ用のWebサーバーは、インターネットに
公開出来るが、両方同時には、公開出来ないということですね。


同時に同じポートはだめでした。

No.6240 投稿時間:2002年11月06日(Wed) 00:14 投稿者名:kazu URL:

80 8080
An httpd ○ ×
カメラ ○ ×

という事です。同時に同じポートはだめでした。


単独でアクセス出来ましたか?

No.6245 投稿時間:2002年11月06日(Wed) 00:54 投稿者名:鷹の巣 URL:http://sakaguch.com/

>         80   8080
> An httpd    ○         ×
> カメラ       ○     ×
> 
> という事です。同時に同じポートはだめでした。

同じポートの同時使用は、始めから駄目だということは、解っています。
8080番で、Webサーバー単独でアクセス出来ましたか?
8080番で、カメラ用サーバー単独でアクセス出来ましたか?


8080単独ではだめです。

No.6260 投稿時間:2002年11月06日(Wed) 21:09 投稿者名:kazu URL:

> 同じポートの同時使用は、始めから駄目だということは、解っています。
> 8080番で、Webサーバー単独でアクセス出来ましたか?
> 8080番で、カメラ用サーバー単独でアクセス出来ましたか?
度々すみません。8080単独ではだめです。
ローカルではOKなんですが...?


AN HTTPD単独で、8080番で、インターネット側からアクセスできますか?

No.6278 投稿時間:2002年11月07日(Thu) 23:57 投稿者名:鷹の巣 URL:http://sakaguch.com/

> > 同じポートの同時使用は、始めから駄目だということは、解っています。
> > 8080番で、Webサーバー単独でアクセス出来ましたか?
> > 8080番で、カメラ用サーバー単独でアクセス出来ましたか?
> 度々すみません。8080単独ではだめです。
> ローカルではOKなんですが...?

ということは、ルータの設定不良がまず、一番に考えられますが、
カメラ用サーバーを全く使用せずに、AN HTTPD単独で、8080番で、インターネット側から、
http://example.com:8080/
でアクセスできますか?


単独ではだめです。

No.6313 投稿時間:2002年11月09日(Sat) 16:59 投稿者名:kazu URL:

> ということは、ルータの設定不良がまず、一番に考えられますが、
モデムも80ポートと同じように8080が開いてあります。
ブロードバンドルーターも80ポートと同じように8080が開いてあります。

> カメラ用サーバーを全く使用せずに、AN HTTPD単独で、8080番で、インターネット側から、
> http://example.com:8080
> でアクセスできますか?

単独ではだめです。http://example.com:8080
ローカルでIP:8080では見れます。何故でしょう???


サービスポート8080番は、openになっていないのでしょうか?

No.6325 投稿時間:2002年11月10日(Sun) 00:05 投稿者名:鷹の巣 URL:http://sakaguch.com/

> > カメラ用サーバーを全く使用せずに、AN HTTPD単独で、8080番で、インターネット側から、
> > http://example.com:8080
> > でアクセスできますか?
>
> 単独ではだめです。http://example.com:8080
> ローカルでIP:8080では見れます。何故でしょう???

ローカルで見れるということは、Webサーバー側の設定は、正しいですね。
インターネット側から見れないとなると、Windows2000の場合は、ルータの設定ということに
なりますが、確認方法にも問題があるかも知れません。こちら
http://sakaguch.com/ServicePort.html
で、サービスポート8080番は、openになっていないのでしょうか?


8080番ポートが開いていませんでした。

No.6337 投稿時間:2002年11月10日(Sun) 10:53 投稿者名:kazu URL:


> で、サービスポート8080番は、openになっていないのでしょうか?

ポートが開いていませんでした。?OCN アッカは8080は開けられないのでしょうか?
モデムの8080とルーターの8080は開けた設定をしていることを確認しています?


Teveoはどうやってポート番号を変更出来るのですか?

No.6239 投稿時間:2002年11月05日(Tue) 23:50 投稿者名:ryujin URL:http://www.ryujin.info/

はじめまして、kazuさん。
この投稿で初めてTeveoを知り試してみました。(汗)
> 簡単なライブカメラ(動画)を設置しようと思いTeveoのフリーソフトをダウンロードしてポート8080で設定。
Teveoはどうやってポート番号を変更出来るのですか?
登録してからなのかな・・・登録はしてない物で。
基本的な質問で、筋違いかもしれませんがよろしくお願いします。


設定ボタンがでてきますよ。

No.6242 投稿時間:2002年11月06日(Wed) 00:22 投稿者名:kazu URL:

ダウンロードして、ソフトを起動させると
出てきますが?設定ボタンがでてきますよ。


設定ボタン?出なかったので

No.6256 投稿時間:2002年11月06日(Wed) 18:09 投稿者名:ryujin URL:http://www.ryujin.info/

> ダウンロードして、ソフトを起動させると
> 出てきますが?設定ボタンがでてきますよ。
出てこない???そこで、\windows\teveolive.iniファイルの
[Init]
Port=80
を8080に変更して
Swikiサーバーを80で動かしてみました。
LAN内でのテストですが共に動きました。
これで良いのかどうかどうか判りませんが参考として記述してみまた。


An httpdを起動した後、TeVeoを起動する。これで問題なく動きました。

No.6286 投稿時間:2002年11月08日(Fri) 11:20 投稿者名:ねこご URL:

> また、同じようなことをやってらっしゃる方がいましたら、アドバイスお願いします。

ここを見かけて、以前失敗した原因が分かったので再挑戦しました。

ルーターの8080番を開く。An httpdでポート番号を8080番に設定する。
An httpdを起動した後、TeVeoを起動する。これで問題なく動きました。
An httpd80番×TeVeo8080番は試していません。

TeVeoはソフトが動いていてもインターネットで見えないこともあるので、
TeVeoのHPに登録しておくと便利だと思います。
登録すればTeVeoHPの「Live Cameras」から見られるので、
映っているか確認できます。

あと、TeVeoは動いているのにJava部分だけ落ちていて
見られないことが多々あります。
これは、TeVeoHPで見ると背景は映っているのに映像だけ映っていない、
PC上でカメラ表示部分が青い画面になったまま映らないので分かります。

うちのPCの場合、一番止まる確率が高いのが起動時で、
他のソフト、An httpdを起動した後、TeVeoを起動すると順調に動きます。
どれかのソフトよりTeVeoが先になるとほぼ映像は落ちます(T_T)

An httpdへのアクセスはまだ誰にも教えていないので、
An httpdとTeVeoにそれぞれ頻繁にアクセスがあった場合も
動き続けるかは分かりません(^^;

An httpdの方に3回ほどアクセスして
1回はTeVeoが落ちたのでなんとも言えないですが・・・・・・

ちなみに証拠としてアドレスを書いた方がいいでしょうか(^^;
(TeVeoが落ちるとちょっと悲しい・・・・・)


研究してみます。

No.6312 投稿時間:2002年11月09日(Sat) 16:54 投稿者名:kazu URL:

情報有り難うございました。研究してみます。


Re: No.6337 AN HTTPDをまず単独で8080番でインターネットに開放して見て下さい。

No.6341 投稿時間:2002年11月10日(Sun) 14:29 投稿者名:鷹の巣 URL:http://sakaguch.com/

> ポートが開いていませんでした。?OCN アッカは8080は開けられないのでしょうか?
> モデムの8080とルーターの8080は開けた設定をしていることを確認しています?

多分、サービスポート8000番台は、openになると考えます。
どうしても不安であれば、FTPポートの21番で仮に試して見て下さい。


1024番でカメラサーバーがたちました。

No.6349 投稿時間:2002年11月10日(Sun) 22:52 投稿者名:kazu URL:

いろいろすみませんでした。やっぱり8080はだめでした。1024番でカメラサーバーがたちました。
お手数お掛けしました。


ブラウザにプロキシサーバーを設定していませんか?

No.6350 投稿時間:2002年11月10日(Sun) 23:05 投稿者名:鷹の巣 URL:http://sakaguch.com/

> いろいろすみませんでした。やっぱり8080はだめでした。1024番でカメラサーバーがたちました。

ブラウザがIEでしたら、プロキシサーバーの使用するポートは、8080番ですけど、
プロキシサーバーを設定していませんか?


チェックはとれていました。何故でしょう?

No.6352 投稿時間:2002年11月11日(Mon) 02:37 投稿者名:kazu URL:

>> ブラウザがIEでしたら、プロキシサーバーの使用するポートは、8080番ですけど、
> プロキシサーバーを設定していませんか?
何回もすみません
インターネットオプションですよね?
チェックはとれていました。何故でしょう?


|目次|掲示板|過去ログ目次|▲頁先頭|