投稿日:2002年10月30日 作成鷹の巣

No.6098 Windows98でアクティブパールがインストールできない。



Windows98でアクティブパールがインストールできない。

No.6098 投稿時間:2002年10月30日(Wed) 23:22 投稿者名:98 URL:

当方win98でActiveperlインストールしようとしたら出来ませんでした。

インストーラーはperlのサイトに記載されていたものをダウンロードしました。
インストール画面は出てきてインストールし終わる寸前に
installer information
there is a problem with this windows
installer package. a script requierd for this
install to complate could not be run. contact
your support personnel or package vendor

って出てきてインストール出来ません。
なぜでしょう・・・お願いします。


9x系はWindowsInstaller2.0+が必要です。

No.6099 投稿時間:2002年10月30日(Wed) 23:44 投稿者名:おやじ URL:http://www.aconus.com/~oyaji/

> 当方win98でActiveperlインストールしようとしたら出来ませんでした。
>
> インストーラーはperlのサイトに記載されていたものをダウンロードしました。
> インストール画面は出てきてインストールし終わる寸前に
> installer information
> there is a problem with this windows
> installer package. a script requierd for this
> install to complate could not be run. contact
> your support personnel or package vendor
>

下記の右側のActivePerl Notesに98系はWindowsInstaller2.0+が必要と
書いてありますよね。

http://www.activestate.com/Products/Download/Download.plex?id=ActivePerl


インストーラ2.0は使用しています。

No.6108 投稿時間:2002年10月31日(Thu) 14:36 投稿者名:98 URL:

> > インストール画面は出てきてインストールし終わる寸前に
> > installer information
> > there is a problem with this windows
> > installer package. a script requierd for this
> > install to complate could not be run. contact
> > your support personnel or package vendor
> >
>

インストーラ2.0は使用しています。


ウイルス対策ソフトは動いていませんか?

No.6118 投稿時間:2002年10月31日(Thu) 20:24 投稿者名:おやじ URL:http://www.aconus.com/~oyaji/

>
> > > インストール画面は出てきてインストールし終わる寸前に
> > > installer information
> > > there is a problem with this windows
> > > installer package. a script requierd for this
> > > install to complate could not be run. contact
> > > your support personnel or package vendor
> > >
> >
>
> インストーラ2.0は使用しています。

大変失礼をしました。インストールの最後というのを見落としていました。
今、娘のPC(Windows98SE)にInstallerを入れ、MSIをインストールしてみましたが、
すんなり入ってしまいました。で、考えてみるに最後の方でエラーがでるとなると、
AUTOEXEC.BATにPATHを書き込むフェーズではないかと思います。
ウイルス対策ソフトは動いていませんよね。AUTOEXEC.BATはシステムファイルです
からプロテクトされますので。動作しているなら止めてみてください。インストール時は
止めるのが原則です。
だとすれば、AUTOEXEC.BATを編集して、下記を追加して再起動すれば動くかも知れません。
C:\USR\BINのところは、perl.exeがあるフォルダを指定してください。

SET PATH=C:\USR\BIN;%PATH%


IEが古くないですか?

No.6121 投稿時間:2002年10月31日(Thu) 21:23 投稿者名:いと URL:

> インストーラ2.0は使用しています。

以下のページの「Perlのインストール」の(注4)が該当しませんか?
http://homepage1.nifty.com/yito/anhttpd/install.html

もしそうで、IEのバージョンを上げたくないということであれば、
ActivePerlの方を build 629以前にするという手があります。
http://downloads.activestate.com/ActivePerl/Windows/5.6/

zipと msiがあるので必ず msiの方をダウンロードしてください。


|目次|掲示板|過去ログ目次|▲頁先頭|