投稿日:2002年08月13日 作成鷹の巣

No.4567 Red Hat Linux 7.3にwu-ftpのFTPサーバにインターネットのブラウザからアクセス出来ません。



Red Hat Linux 7.3にwu-ftpのFTPサーバにインターネットのブラウザからアクセス出来ません。

No.4567 投稿時間:2002年08月13日(Tue) 03:09 投稿者名:モモ URL:

Red Hat Linux 7.3にwu-ftpを入れてます。ACCA + So-net8M(富士通モデム)
192.168.0.1がルータ 192.168.0.2がサーバ 192.168.0.3がクライアントです

クライアントからブラウザでftp://192.168.0.2を表示してアップとダウンをすると両方とも出来ます。
ルータをTCP 開始ポート20 最終ポート21 ローカルIPアドレス192.168.0.2のように設定してポートを開放していますが
WAN側からは見れません。
webサーバも立てていますが、LAN側からは普通に見れます、WAN側からはプロキシサーバを使うと見れる状況です。
FTPもプロキシを通さないと、ページを表示できませんと言う表示になり、プロキシを通すとFTP Server Errorと出てしまいます。

どこらへんが悪いのでしょうか?
よろしくお願いします。


外部からプロキシサーバを使用せずにFTPサーバーに接続して、動作試験を行って頂けませんか。

No.4591 投稿時間:2002年08月14日(Wed) 08:47 投稿者名:鷹の巣 URL:http://sakauch.com/

> ルータをTCP 開始ポート20 最終ポート21 ローカルIPアドレス192.168.0.2のように設定してポートを開放していますが
> WAN側からは見れません。
> webサーバも立てていますが、LAN側からは普通に見れます、WAN側からはプロキシサーバを使うと見れる状況です。
> FTPもプロキシを通さないと、ページを表示できませんと言う表示になり、プロキシを通すとFTP Server Errorと出てしまいます。
>
> どこらへんが悪いのでしょうか?


ご使用のルータでは、LAN内からサーバー機のプライベートでは、アクセス出来てもドメイン名やグローバルアドレスでは、
アクセス出来ないと考えます。
従って、WWWサーバーは、WAN側のプロキシサーバを使うことにより、WAN側からパケットをルータに入れて、
ルータのポートフォワーディングによって、見れています。
FTPの場合も同じことが言えますが、FTPクライアントがブラウザの場合は、
プロキシサーバを使わないとルータにFTP接続して、「ページを表示できません」というエラーになり、
プロキシサーバを使うと、プロキシサーバとルータ間の接続が出来ずに「FTP Server Error」というエラーになっていると推測します。
FTPでプロキシサーバとルータが関係すると難しいので、外部からプロキシサーバを使用せずにFTPサーバーに接続して、動作試験を
行って頂けませんか。

FTPサーバーにルータのNATが入ると基本的には、PORTモードで試験を行って下さいね。
FTPクライアントもブラウザで、PORTモードやPASVモードを設定するのではなく、FTPクライアントの専用ソフトを使用する方が、
ヘルプファイルや作者の掲示板でサポートが受けられます。


私もインターネット側のFTPクライアントからFTPサーバにアクセス出来ません。

No.4673 投稿時間:2002年08月21日(Wed) 00:35 投稿者名:じーまん URL:

> Red Hat Linux 7.3にwu-ftpを入れてます。ACCA + So-net8M(富士通モデム)
> 192.168.0.1がルータ 192.168.0.2がサーバ 192.168.0.3がクライアントです
>
> クライアントからブラウザでftp://192.168.0.2を表示してアップとダウンをすると両方とも出来ます。
> ルータをTCP 開始ポート20 最終ポート21 ローカルIPアドレス192.168.0.2のように設定してポートを開放していますが
> WAN側からは見れません。
> webサーバも立てていますが、LAN側からは普通に見れます、WAN側からはプロキシサーバを使うと見れる状況です。
> FTPもプロキシを通さないと、ページを表示できませんと言う表示になり、プロキシを通すとFTP Server Errorと出てしまいます。
>
> どこらへんが悪いのでしょうか?
> よろしくお願いします。



自分もaccaの富士通「Flashwave2040」で同じことをトライしていますがFTPソフトでも外部アクセスはできません。
「有効スタティックIPマスカレード」できちんとポート指定もしてます。「DMZ」でもだめなんですが・・・・
結局モデムを「ブリッジ」で動作させて使用しています。
出来たという話しは無いんでしょうか??
ちなみに「HTTPD」と「Tiny FTP Daemon」を使用しています。


|目次|掲示板|過去ログ目次|▲頁先頭|