投稿日:2002年05月18日 作成鷹の巣

No.3126 CGIを起動させたいのですが、エラー500といってアクセスできません。



CGIを起動させたいのですが、エラー500といってアクセスできません。

No.3126 投稿時間:2002年05月18日(Sat) 12:50 投稿者名:Shoki URL:

CGIを起動させたいのですが、エラー500といってアクセスできません。
WWWソフトは、AN HTTPDを使ってますがいまだにできません。
どうすればよいでしょう?


ActivePerl 5.6.1 はインストールされてるでしょうか?

No.3127 投稿時間:2002年05月18日(Sat) 13:27 投稿者名:トンガリ URL:http://www.bj.wakwak.com/~kusa/tongari/

ちなみにお聞きしますが
ActivePerl 5.6.1
はインストールされてるでしょうか?
僕もこれが入ってなかったのでCGI起動が大変でした。


それはちゃんとインストールされています。

No.3128 投稿時間:2002年05月18日(Sat) 13:40 投稿者名:Shoki URL:

返事ありがとうございます。それはちゃんとインストールされています。


もう少し詳しいエラー表示を教えて下さい。

No.3131 投稿時間:2002年05月18日(Sat) 14:25 投稿者名:鷹の巣 URL:http://sakaguch.com/

> 返事ありがとうございます。それはちゃんとインストールされています。


500番のエラーに関しましては、
http://www.kent-web.com/support/faq/index.html
をご参照願います。

もう少し詳しいエラー表示を教えて下さい。
1.ブラウザの「ツール」-「インターネット オプション」の「詳細設定」タブのブラウズで、
「HTTPエラーのエラーメッセージを簡易表示する」のチェックは、外してありますでしょうか。
2.AN HTTPDの一般アブの下の方の「CGI出力を検査」 にチェックを入れて下さい。

もう少し詳しいエラー表示がなされないと
http://homepage1.nifty.com/yito/anhttpd/error.html#500
等のデータが役に立ちません。


原因が解るまで、徹底的に調べたいところですが、
基本的に
1.windows のレジストリエディタ(regedit.exe)にて、HKEY_LOCAL_MACHINE\Software\AnHttpd以下の
レジストリデータを一旦削除して、再インストールして下さい。
ダウンロード先は、こちら
http://www.vector.co.jp/soft/dl/win95/net/se044252.html
に安定バージョン1.37dがあります。
2.インストール後変更するところは、基本的に「一般」タブの拡張子「.pl,.cgi」行の実行プログラムを
「perl」から、「C:\Perl\bin\perl.exe 」にするだけで、良いと考えます。
(perlのインストール先がC:\Perlであると仮定しています。)
3.動作不良の出るCGIが既成のCGIである場合は、その配布サイトを明示して頂く必要がありますが、
その前にテスト用のCGIを作成してテストして下さい。


よく読んだ結果、掲示板を使えるようになりました。

No.3154 投稿時間:2002年05月19日(Sun) 04:04 投稿者名:Shoki URL:

返事ありがとうございます。
それをよく読んだ結果、掲示板を使えるようになりました。
ありがとうございました。


|目次|掲示板|過去ログ目次|▲頁先頭|