投稿日:2002年04月21日 作成鷹の巣

No.2578 メールサーバについて…



メールサーバについて…

No.2578 投稿時間:2002年04月21日(Sun) 14:35 投稿者名:としちゃん URL:

はじめまして
としちゃんと申します。
自宅でサーバーと鷹の巣のホームページを見て、メールサーバーをたてました。
no-ip.comでアカウントを作成しました。
それを使ってパソコンからsmtp送信をしてもエラーになりませんが、そのパソコンでの受信も出来ますが、
他からのパソコンや携帯からメール送信をしても、そのメールは受信が出来ません。
これは、どういうことでしょうか?
no-ip.comでの登録が成功していないのでしょうか?
popサーバーが機能していないのでしょうか?
ぜひ教えてください。
よろしくお願い致します。


表F2の内容のチェックを行って下さい。

No.2581 投稿時間:2002年04月21日(Sun) 18:46 投稿者名:鷹の巣 URL:http://sakaguch.com/

> 自宅でサーバーと鷹の巣のホームページを見て、メールサーバーをたてました。
> no-ip.comでアカウントを作成しました。
> それを使ってパソコンからsmtp送信をしてもエラーになりませんが、そのパソコンでの受信も出来ますが、
> 他からのパソコンや携帯からメール送信をしても、そのメールは受信が出来ません。


つまり、user@xxx.no-ip.comから、user@provider.comへの送信は、可能で
user@provider.comからuser@xxx.no-ip.comへの送信が出来ないということですね。
メールの送受信共、サービスポート25番を使用するのですが、ルータのポートフォワーディングをしていなくても送信は出来ます。

手順F.メールサーバー動作の確認
http://sakaguch.com/MailServer.html
の項5で引っかかっている訳ですから、表F2の内容のチェックを行って下さい。

通常、以下の何れかを再度、ご確認して下さい。
1.no-ip.comのMXレコードの設定。
2.ルータのサービスポート25番のポートフォワーディング。

> no-ip.comでの登録が成功していないのでしょうか?


no-ip.comでのMXレコードの可能性があります。

xxx.no-ip.com MX 10 xxx.no-ip.com (ダイナミックDNSでは、既に設定されているものもあります。)


> popサーバーが機能していないのでしょうか?


LAN内では着信できるのですから、popサーバーとメールクライアントの設定は正常だと考えます。


MXレコードの設定を調べたのですが...

No.2583 投稿時間:2002年04月21日(Sun) 19:59 投稿者名:としちゃん URL:

鷹の巣さんへ
ご返事、ありがとうございました。
> 通常、以下の何れかを再度、ご確認して下さい。
のご指導に従いました。
> つまり、user@xxx.no-ip.comから、user@provider.comへの送信は、可能で
> user@provider.comからuser@xxx.no-ip.comへの送信が出来ないということですね。
パソコンからuser@xxx.no-ip.com宛に送信して、それを受信できるのですが、
他からのパソコンでは受信できませんでした。
それで、まず、nslookupで
no-ip.comのMXレコードの設定を調べたのですが、
どうも設定がされていないようです。
それで念のためzive.netでも設定を行い、nslookup
で調べたところ以下の様になり成功しているようですが、
Non-authoritative answer:
Server: ml1.-----.ne.jp
Address: ------
----.zive.net MX preference = 10, mail exchanger = ----14125.adsl.ppp.infoweb.ne.jp
(--で主要なところはかくしてあります)
このzive.netのアカウントでも他からのパソコンで送信すると
送信エラーが帰ってきます。(エラー番号550)
それで鷹の巣のメールサーバーのF&Qの不具合内容と訂正個所
> 登録されたユーザでない。メール送信するには、認証が必要。
> メールサーバの「Tools」-「Options」のSMTP Authentication タブの設定で、
> Enable SMTP Authentication と Use POP3 User Names and Passwords に
> チェックを入れ、User Properties の設定でユーザー名とパスワードを設定し、
> SMTP-LOGIN認証機能を正しく行なって下さい。
上記で
このユーザー名とパスワードは勝手に作ったものでいいのでしょうか?
次に
2.ルータのサービスポート25番のポートフォワーディング。
ですが、
これは私のルータでは手動で設定はしているのですが、
コマンド状況も以下のように見れるのですが、自信がありません。
nat 0 192.168.000.003 192.168.000.003 * www 000.000.000.000
nat 1 192.168.000.002 192.168.000.002 * www 000.000.000.000
nat 2 192.168.000.003 192.168.000.003 * ftp 000.000.000.000
nat 3 192.168.000.002 192.168.000.002 * ftp 000.000.000.000
nat 4 192.168.000.004 192.168.000.004 * smtp 000.000.000.000
nat 5 192.168.000.004 192.168.000.004 * pop3 000.000.000.000
nat 6 192.168.000.003 192.168.000.003 * pop3 000.000.000.000
nat 7 192.168.000.003 192.168.000.003 * smtp 000.000.000.000
nat 8 * * * * 000.000.000.000
この設定が反映されているかどうかを調べるのはどうしたらいいのでしょうか?
ArGoSoft Mail Serverのログでは解らないでしょうか?
どうも初歩的な質問でご迷惑をおかけしているかもしれませんが、
よろしくお願い致します。

> > 自宅でサーバーと鷹の巣のホームページを見て、メールサーバーをたてました。
> > no-ip.comでアカウントを作成しました。
> > それを使ってパソコンからsmtp送信をしてもエラーになりませんが、そのパソコンでの受信も出来ますが、
> > 他からのパソコンや携帯からメール送信をしても、そのメールは受信が出来ません。
>
>
> つまり、user@xxx.no-ip.comから、user@provider.comへの送信は、可能で
> user@provider.comからuser@xxx.no-ip.comへの送信が出来ないということですね。
> メールの送受信共、サービスポート25番を使用するのですが、ルータのポートフォワーディングをしていなくても送信は出来ます。
>
> 手順F.メールサーバー動作の確認
> http://sakaguch.com/MailServer.html
> の項5で引っかかっている訳ですから、表F2の内容のチェックを行って下さい。
>
> 通常、以下の何れかを再度、ご確認して下さい。
> 1.no-ip.comのMXレコードの設定。
> 2.ルータのサービスポート25番のポートフォワーディング。
>
> > no-ip.comでの登録が成功していないのでしょうか?
>
>
> no-ip.comでのMXレコードの可能性があります。
>
> xxx.no-ip.com MX 10 xxx.no-ip.com (ダイナミックDNSでは、既に設定されているものもあります。)
>
>
> > popサーバーが機能していないのでしょうか?
>
>
> LAN内では着信できるのですから、popサーバーとメールクライアントの設定は正常だと考えます。


|目次|掲示板|過去ログ目次|▲頁先頭|