投稿日:2002年04月14日 作成鷹の巣

No.2455 ANHTTPDでたまに反応しなくなるのですが



ANHTTPDでたまに反応しなくなるのですが

No.2455 投稿時間:2002年04月14日(Sun) 13:18 投稿者名:アッキー URL:

当方DDNS+ANHTTPD(WindowsXPPro上)でサーバを運営してるのですが
たまにサーバの反応がなくなります。でその時にNTサービスをはずしてあげると反応しはじめるの
ですが、またその状態でほっとくと反応しなくなり、逆に今度はNTサービスとして実行してあげると
まあ反応しはじめたりするのです。こういう現象ってANHTTPDの方のホームページでも
見た事ないですし、他に遭遇した人いないですかね?
最初はDDNSの問題かと思い、とりあえずいくつかかえてみて、今は有料のDyn.TOに
したのですが、症状は改善されず、ならばとルーターかなと思い、他のルーター買ってきて
みても結局改善されず、プロバイダも乗り換えてみたけどダメでした。一応身内だけで掲示板だけの
ページなので、皆さん殆どMAMIMIっていうminiBBSを巡回するソフトでアクセス
されてるのですが、その辺が原因て事もありえますかね?
最終的にアパッチェあたり研究して乗り換えてみようかなとも思ってますが、ANHTTPDが
使いやすいだけにいまいち踏み切れません、多分毎日定時にOSを再起動とかさせてやれば
問題ないとは思うのですが....

ちなみに反応ないというのはIEとかでアクセスした場合に、そんなページないって言われて
しまう状態です。(404でしたっけ?)


安定バージョンを使用されていますか。

No.2460 投稿時間:2002年04月14日(Sun) 21:22 投稿者名:鷹の巣 URL:http://sakaguch.com/

> 当方DDNS+ANHTTPD(WindowsXPPro上)でサーバを運営してるのですが
> たまにサーバの反応がなくなります。でその時にNTサービスをはずしてあげると反応しはじめるの
> ですが、またその状態でほっとくと反応しなくなり、逆に今度はNTサービスとして実行してあげると
> まあ反応しはじめたりするのです。こういう現象ってANHTTPDの方のホームページでも
> 見た事ないですし、他に遭遇した人いないですかね?


要は、AN HTTPDを再起動すれば、動き出すというのと同じことだと考えます。


> 最初はDDNSの問題かと思い、とりあえずいくつかかえてみて、今は有料のDyn.TOに
> したのですが、症状は改善されず、ならばとルーターかなと思い、他のルーター買ってきて
> みても結局改善されず、プロバイダも乗り換えてみたけどダメでした。一応身内だけで掲示板だけの


やはり、AN HTTPDが原因ですね。バージョンは、何でしょう。
AN HTTPDのホームページで公開されている最新バージョンより、Vector辺りから、タウンロード出来る安定バージョンを使用されていますか。


> ページなので、皆さん殆どMAMIMIっていうminiBBSを巡回するソフトでアクセス
> されてるのですが、その辺が原因て事もありえますかね?


MAMIMIというUser Agentは、良く知らないのですが、ご利用のCGIにも問題があるかも知れませんね。
CGIに関して動作が不安定という場合は、
1.どこのサイトの何と言うCGIのバージョンをご使用なのか
2.CGIは、どんなもの(ex. Active Perlのperl.exe等)を使っているのか
等を明示すべきだと考えます。

# この内容に関しては、ご相談を受けても、明確な回答を出す技術力を持っていませんけど。


> 最終的にアパッチェあたり研究して乗り換えてみようかなとも思ってますが、ANHTTPDが
> 使いやすいだけにいまいち踏み切れません、多分毎日定時にOSを再起動とかさせてやれば
> 問題ないとは思うのですが....


OSを再起動というよりもAN HTTPDを再起動ということですね。


> ちなみに反応ないというのはIEとかでアクセスした場合に、そんなページないって言われて
> しまう状態です。(404でしたっけ?)


Error 312 Cannot connect to the server では、ありませんか。


|目次|掲示板|過去ログ目次|▲頁先頭|